Dynamo 1.2.1 refuses to install

Dynamo may not work for many reasons, but in this case it just won’t install.
I’ve tried removing every previous version of dynamo (0.9 works, but nothing higher).

I’m working with Revit 2015.

Hi, that’s because Revit 2015 can “host” only dynamo 0.9 or lower, there is no more support from newer versions of Dynamo to Revit 2015. Hope this will help you.

@Ernesto_Pellegrino According to the dynamo primer website revit 2015 can have up to 1.2.1 installed.


1 Like

@Brendan_Cassidy this is the officla website, please have a look here.


Think if you look for the daily builds page you can still get an installer that will install Dynamo 1.2.1 into Revit 2015, I have a copy of one of them that i’ve used recently.
think it was 1.2.2 on wards that stopped working with 2015

If not 1.2.1 - then certainly 1.2.0 will


1 Like

To clarify I’ve already had Dynamo 1.2.1 installed for Revit 2015, but I’ve now moved to a different computer, Revit 2015 already installed, but can’t manage to reinstall dynamo.

I wouldn’t mind so much, if I hadn’t already made quite a number of Dynamo files, which I now can’t open.

Edit, I can’t install version 1.0.0 either, I think the issue lies with the versions of Dynamo which can only be opened with Revit itself.

do you have 2017 or 2018 on the machine as well? once 1.3.2 is installed lower versions become inoperable. at least that has been my experience. I have a side machine dedicated to 2015 and 1.2.1

1 Like

That’s a good question, but I do not.

It’s not just the issue that it doesn’t load in Revit though, it doesn’t show up at all in any program files folder.

I had the same problem and stumbled across this thread. Even though it didn’t show up in Apps & Features, the Core for 1.3.2 was still hanging around. Using IOBit Uninstall Utility (as suggested in another thread) I was able to uninstall the 1.3.2 core and then 1.2.1 installed correctly

1 Like

As far as I know Dynamo 1.3 was never installed on this system and neither does the IOBit Utility show it.

…IOBit Utility however is a piece of software that can help me with some very different issues I’ve had so thanks for bringing it to my attention.

Not sure if you have attempted this already:

Try uninstalling all things dynamo via add/remove programs, including studio, 0.9, dynamo core, dynamo for. Revit… all of it. Then use Microsoft’s FixIt utility to clean out the registry. At this point searching your programs folder for Dynamo should yield no results, and you should have no Dynamo inside Revit. Then restart your CPU.

After that install 1.2.1 (assuming you’re still in 2015, otherwise go 1.3.2) and see where that gets you.

I have done so, but I used IOBit Utility to remove everything Dynamo.
But it has been no use, Dynamo 1.0 or higher simply doesn’t seem to get installed anywhere in the first place, it runs the installation file but simply isn’t installed.

Interesting… let me see if I can come up with anything - can you let me know what OS you’re on and such? Any VM going on? Or odd security stuff?

Errrr, I’m on Windows 7 64 bit. That’s about as much as I know. I don’t think I’m dealing with VM’s but I’m connected to quite a number of servers, I don’t know about any odd security stuff.
I’m generally fine without updating it to a version 1 though.

In my latest random attempt to install it it actually installed.
I didn’t do anything differently than the previous times but it worked out.

1 Like