Dynamo 1.3.2 doesn't install for Revit 2016

I tried to install Dynamo Revit 1.3.2 because I have Revit 2016 & 2017, but I can’t install it.
Cattura29
What can I do? Thanks

Have you installed another version already? Can you send us a screenshot of every Dynamo version and type installed on your system?

Cattura28
I’ve just “Core 1.3.2”

Uninstall that (and any other dynamo installed that you can find), run Microsoft’s FixIt utility, and then try a reinstall.

I don’t understand… If I install Dynamo 1.2 or 2.0, It’s all ok.
But if I try to install 1.3.xx, i can’t… WHY?

My guess: as a result of a bad update or a bad install you have a corrupted registry. Did you try the uninstall and FixIt utility as I indicated? That would confirm.

What kind of “Fix It Utility” have I to use?

Has its own site now.

http://fixitcenter.support.microsoft.com/Portal/FindSolutions

The link does not work

Sorry my old link was broken as they’ve re-branded it again apparently…

https://support.microsoft.com/en-us/help/2970908/how-to-use-microsoft-easy-fix-solutions

which one should I choose?

I got the same message. I removed 1.3.3 and I can’t reinstall 1.3.2.

Ideas?

image

I re-Installed Dynamo 1.3.3. But I can’t re-install 1.3.2

The following solutions didn’t work for me:

image

While Autodesk decide whether to do anything about this issue, I have found my own dodgy workaround. I found a post on GitHub where some service pack for Revit 2017 did the same thing - someone suggested copying the Dynamo installed files for 2016 to a safe place before installing the new version of Revit/Dynamo - then copying them back afterwards. In my case it was too late, so I found the installed dynamo files on another computer and copied them to the computer where they’d been blitzed. Much to my surprise it worked, and I now have Dynamo 1.2 on Revit 2016 and Dynamo 1.3.3 on Revit 2019. The folders are:

C:Program Files\Dynamo\Dynamo Core\1.2
C:Program Files\Dynamo\Dynamo Revit\1.2\Revit_2016
(or 1.3.2 in your case)

Then copy the ‘Dynamo.addin’ file from:
C:\ProgramData\Autodesk\Revit\Addins\2016

Copy those folders and files back to the equivalent place after the Revit 2019 installer has done its stuff.

I can’t promise it will work for you; and please be very careful messing around in the program Files folder (I wouldn’t normally recommend it).
Uninstallers obviously won’t work on this; and not sure what’ll happen when you install another newer version of Dynamo?

@salvatoredragotta did you try using the microsoft fix it utility to cleanup the registry?

@Lpiu, @salvatoredragotta, directions on using the Fix It Utility can be found here, including a working link to download the tool.

I ended up restoring the registry to a point I created before installing Revit 2019.

This method worked!

Remove all files in the following folder:

C:\Users\User Name\AppData\Roaming\Dynamo

Then install Dynamo 1.3.2.

Before I did this, I uninstalled all versions of Dynamo. I installed 1.3.2 and then 2.0.1.