Cannot open Dynamo in Revit

Can anyone help me diagnose this issue?

image

Thanks!

  1. Restart the CPU
  2. Open Revit,
  3. Start a new file
  4. Launch Dynamo to reproduce the issue
  5. Hit ok, an quit Revit
  6. Post your Revit journal a Dynamo Log file (assuming one is created when this happens - check the time stamp)

Alternatively: Contact Autodesk support via the accounts portal at Manage.Autodesk.Com

1 Like

dynamoLog_de0faaa4-8245-4c3c-957e-5fa6491f8b9f.txt (38.4 KB)

Revit journal?

Looks as if you have packages on the J drive and your C drive. Assuming the J drive is a network drive, try remove the J drive reference in Dynamo and see if that resolves some of the issues.

journal.0144.txt (328.2 KB)

Thank you for your suggestions. I really appreciate the help. Unfortunately I am unable to access dynamo at all. The original picture I posted comes up immediately after I click on dynamo, so I cannot access dynamo to remove the packages that its looking at on the J drive. Yes, you are correct that the J drive is our network drive where I keep the packages and I also have them on my C drive.

Did this trigger the pop up? Don’t see it in the journal.

Try disabling PyRevit as a first step. Lots of conflicts there. If not that disable all Revit add-ins as a next step.

You could also try renaming your local Dynamo package library to fix the log issue there, but since you aren’t getting into dynamo that shouldn’t be the issue.

Do you have bird tools raven installed?
Try disabling it and other Revit addins as a test.

Some initial feedback from the development team indicates that this may be something readily identifiable by checking your Dynamo revit folder for the GregRevitAuth.dll file. This is typically located at:

C:\ProgramFiles\Autodesk\Revit 2021\AddIns\DynamoForRevit\Revit\GregRevitAuth.dll

Can you find that file, right click on it, get the details, and find out what the product version listed is on the details tab?

I tried uninstalling pyRevit and didn’t have any luck. I will try to remove all other add-ins next. I have found the GregRevitAuth file for Revit 2021 and will post snip below:

2 Likes

Yes, it triggers a pop up. I will work on getting the other add-ins removed. This has occurred for all versions of Revit that I have (20,21,22). Reverting back to a previous version has solved it in the mean time but Id like to find a better way to combat this.

Hi @amcaleese can you also share the version of Greg.dll you find in the Dynamo folder? If there are more than one of these binaries please share all version numbers and locations.

1 Like

Hey Michael, Thank you for your input as well. I appreciate all the help I can get. Regarding the Greg.dll file, I have attached a photo below. The other files I was able to find are the other “Greg.dll and GregRevitAuth.dll” files for Revit versions 20,21,22. Would it be helpful to see the info for those?

1 Like

ugh, thank you for the information - I have something for you to try if you have the time/risk tolerance -
with all of your .addins installed- can you replace the GregRevitAuth binary with this one:

you’ll have to open this with something like nugetexplorer to find the binary - make sure to save your original binary.

I am curious to see if you can continue using all your addins and Dynamo when this binary is updated to the latest version.

1 Like

Has there been any new information on what’s happening here? We’re starting to see this pop up more and more.

I tried to remove the addins as suggested above and that didn’t seem to solve the issue. I ended up reverting back to a previous release of each Revit version for a quick work around.

1 Like

@Nick_Boyts can we do a screen share with you and an impacted user so that we can troubleshoot together?

1 Like

You’re in luck, I’m now one of the impacted users - so definitely. I haven’t had much time to look into myself but will try to do so this afternoon (to at least pinpoint any problematic add-ins). I’m wide open tomorrow or Wednesday so feel free to shoot me a meeting time whenever you’re free.

Once you find a viable solution, could you please update us back on this post? I am also free tomorrow afternoon if there’s anything I can do to help.

1 Like

Has there been any updates on this issue or has it been solved? My office is now running into this issue with Revit 2022 right now.

hello everybody, here i am with the same %%% isssue on Revit 2021. Did you try unistall and install Revit? I’m going to try with this solution.

Plus, I have both 2019 and 2021 installed on my pc and in the 2019 one is still working.

Best.