Cannot get Dynamo in Revit 2021 to Launch

I recently have had an issue pop up that is preventing Dynamo from opening in Revit 2021. No other versions of dynamo are effected that I can tell. the error message I get is this:


Seems to be very similar to post Fail to launch Dynamo in Revit 2021.

I have tried a full uninstall and reinstall of Revit 2021. That didn’t resolve the issue.
Any recommendations?

Can you post the Revit journal and Dynamo log?

Sure thing. I pulled the Dynamo log from here:
%appdata%\Dynamo\Dynamo Revit\2.6\Logs
It won’t let me upload it as it’s 0MB. did i go tot he wrong location?

The Journal file is here:
journal.0002.txt (344.6 KB)

I’d try to launch Revit without any add-in enabled. Maybe some other component from them is preventing Dynamo from starting correctly.
See How to disable add-ons for Revit | Revit | Autodesk Knowledge Network

Disabling add-ins in the next step. In review of the journal, these lines stood out, but you should disable stuff like PnID modeler, BIM Interoperability Tools, and the like as well:

’ 0:< API_SUCCESS { Starting External Application: Precast for Revit, Class: Adsk.RPCA.Core.PrecastStartup, Vendor : RPCA(Autodesk,, Assembly: Autodesk.Precast.Application.dll }
’ 0:< API_SUCCESS { Starting External Application: Enscape 3D, Class: Enscape.Revit.Plugin.EnscapeRevitPlugin, Vendor : Enscape(Enscape GmbH,, Assembly: C:\Users\dwarren\AppData\Local\Programs\Enscape\Bin64\Enscape.Revit.Plugin.2021.dll }
’ 0:< API_SUCCESS { Starting External Application: BluebeamAddin, Class: Bluebeam.BbRevit.RevitAddin, Vendor : BBSI(Bluebeam Revit Plugin), Assembly: C:\Program Files\Bluebeam Software\Bluebeam Revu\20\Pushbutton PDF\Revit\Revit2021\BbRevitAddin2021.dll }
’ 0:< API_SUCCESS { Starting External Application: COINS Section Box App, Class: Coins.Revit.SectionBoxApp.CoinsSectionBoxMenu, Vendor : COIN(COINS,, Assembly: .\CoinsSectionBoxApp2021.dll }
’ 0:< API_SUCCESS { Starting External Application: DatasmithRevitExporter, Class: DatasmithRevitExporter.DatasmithRevitApplication, Vendor : com.epicgames(Epic Games,, Assembly: DatasmithRevit2021\DatasmithRevit2021.dll }
’ 0:< API_SUCCESS { Starting External Application: Ideate Software, Class: Ideate.RevitExtApp.IdeateSoftwareISW.Application.IdeateSoftwareApplication, Vendor : IDSW(Ideate Software,, Assembly: C:\Program Files\Ideate\Ideate Software 2021\IdeateSoftwareISW.dll }
’ 0:< API_SUCCESS { Starting External Application: IMAGINiT.ClarityClient, Class: ClarityClient.ExternalApp, Vendor : RAND(), Assembly: .\ClarityClient21.dll }
’ 0:< API_SUCCESS { Starting External Application: Lumion LiveSync for Autodesk® Revit® 2021, Class: RevitExporter.LumionPlugin, Vendor : Act3D(Act-3D B.V.,, Assembly: LiveSyncForRevit_2021.dll }
’ 0:< API_SUCCESS { Starting External Application: Newforma Revit Addin, Class: Newforma.Addins.Revit2021.NewformaAddinMain, Vendor : NEWF(Newforma, Inc.), Assembly: c:\Program Files\Newforma\Twelfth Edition\Project Center\NewformaRevitAddin2021.dll }
’ 0:< API_SUCCESS { Registered an external server: Name(Navisworks 2021); VendorId(Autodesk Navisworks); ServerId(68e1934c-ec3b-410c-8c82-434f0cf25446); ServiceId(a9bdf0fd-2632-429e-bc35-50ebc2b824d2) }
’ 0:< API_SUCCESS { Starting External Application: PyRevitLoader, Class: PyRevitLoader.PyRevitLoaderApplication, Vendor : eirannejad(), Assembly: C:\Users\dwarren\AppData\Roaming\pyRevit-Master\bin\engines\IPY277\pyRevitLoader.dll }
’ 0:< API_SUCCESS { Starting External Application: Unifi Revit 2021 AddIn, Class: UnifiLabs.RevitAddIn.UnifiApplication, Vendor : INVL(UNIFI Labs Inc.,, Assembly: …\Unifi\UnifiLabs.RevitAddIn2021.dll }

The other possible conflict source would be Dynamo packages - rename your packages folder so that Dynamo would start with no external packages loaded.

Once add-ins are disabled and your Dynamo environment is cleared, restart the system and see if it launches.

1 Like

disabled every addin I can find/think of and the issue persists… then i renamed every package folder I can find… same thing. really batty.

Can you post a new journal and the log (unless it’s still empty - deleting that folder might be advisable if so)? I have some Python which confirms add-ins based on that, and from there I’ll try and think up next steps.

OK. All addins that I can find disabled and no package folders.
Dynamo Log is still empty.

journal.0012.txt (145.6 KB)

1 Like

Journal looks to be free of add-ins, so we can likely rule those out as a route cause.

My other thought is that the analytics dll or setting is broken, but a reinstall would have fixed that (or I would think it round have anyway). I’ll ping the team on Tuesday (holiday for us today) and will let you know what they come back with and/or get you in touch.

If you know the name of the .dll i can try to pull it from a machine that’s working. if not, it can wait until tomorrow.

@DWarren_MPS I’ve encountered the exact same error these past few weeks. I haven’t been able to find the source of the issue yet, but I was able to find the general location that seems to be hanging up Dynamo. I’ve been able to successfully launch Dynamo in the same Revit session it errored out in by deleting all content that I can from this directory: %appdata%\Autodesk\ADPSDK

Some data cannot be deleted as it is in use. After waiting 10 seconds or so, I can successfully launch Dynamo from Revit. This is by no means a solution, but perhaps a workaround for the time being. Thank you for taking the time to start this conversation.


Thanks for this, so the plot thickens…. Today I tried literally copying over every dynamo folder from a working machine to my machine I could find. Packages, ProgramData, Program Files, etc. after two hours… no success.

1 Like

Good to know, although not too surprising in this case. The analytics is actually closer to Revit than Dynamo in this particular release, and might actually be a few steps removed from that due to the nature of the analytics tools - they want to be used in multiple applications, so likely not just in the Revit location (if not multiple steps removed from it).

Dev team confirmed this is a tool which is used across multiple programs and as such can be impacted by other application updates. They are looking for a solution, but there doesn’t seem to be an easy fox without breaking something else.

@DWarren_MPS @pete.heibel can you guys please let me know which applications have been installed or updated on your system in the last month, or since you last had Dynamo for Revit 2021 working (whichever is shorter)? Desktop app, desktop connector, AutoCAD, any plugins from Autodesk… no application/tool is too small here.

1 Like

So, Nuking the ADPSDK folder did “fix” dynamo. It now opens! YAY! However, I now have a TON of package conflicts.

@jacob.small my issues started when i tried to load the following Python update Python on my machine here: Release IronPython 2.7.12 · IronLanguages/ironpython2 · GitHub

It failed to apply and I shrugged… then the fun started.

1 Like

Thanks for looking into this @jacob.small. The error was discovered on 01.06.23 (red line). Revit 2021.1.6 was reinstalled on 01.10.23:

Installed Software_Dynamo Error

And here is a list of Dynamo packages installed for Revit 2021:

Any add-in updates? Other tools (ie: I don’t see Desktop connector in there and my gut says that there’s been an update between then and now)?

IronPython wouldn’t have touched it - it’d be an Autodesk tool of some sort… Something with an installer (even one which your IT team ran silently for you).

In my case, 2021.1.7 update causes this problem. OS is Windows 8.1

Ok - that’s helpful. Were any other tools installed or updated around the time of the 2021.1.7 update?