Cannot open Dynamo in Revit

Please submit a support ticket to the Revit team via the accounts portal at Manage.Autodesk.com

Replacing the GregRevitAuth.dll did the trick for me. The one @Michael_Kirschner2 posted and the one with Dynamo 2.13 (Revit 2023) both worked. They seem to be the same version of the DLL (although with different dates, if that even matters.)

@Nick_Boyts can you upload your original binary (the one you replaced) here or email/dm it to me it directly for analysis?

1 Like

Can’t upload it to the thread but feel free to share/do whatever you need to with it.

It’s also happening here with some users:

  • Revit version 2021.1.7, Build: 20220517_1515
  • GregRevitAuth.dll version 1.0.7057.20655
  • Greg.dll version 2.2.0.1080

Replacing GregRevitAuth.dll with version 1.1.7972.27909 from the link by @Michael_Kirschner2 solves the issue.

You don’t need a special tool to open the nupkg, I could open it with winrar, and I could browse to the dll.

I attached the problem dlls: it’s a zip, renamed to txt, so it can be uploaded…

Original dlls GregRevitAuth 1.0.7057.20655.txt (30.4 KB)

Thank you to @Michael_Kirschner2 for the solution to this issue. It has worked for Revit versions 21 and 22. I am still having an issue with Revit 2020. Does anyone know of a solution to fix R20?

Replacing the GregRevit.dll solved it for me as well (Revit 2022.) I haven’t run into any issues with R20 or R22 so far. If needed I did save-out the original DLL and can send it over.

UPDATE!!

I had to remove the GregRevitAuth.dll completely from the library and then add it back in. That seemed to do the trick. Trying to just save over it for R20 didn’t work, not sure why.

Thanks everyone for the help!

Just happened out of the blue for me this morning in 2020 and 2022. I was working a couple days ago in it without incident, no updates to speak off except Microsoft.

image

Replacing the GregRevitAuth solved the issue for me as well.

3 Likes

Where would one find a replacement Greg files? Could you send me one? for Revit 2020?

On the site @Michael_Kirschner2 linked (NuGet Gallery | GregRevitAuth 1.1.7972.27909) click on download package on the right side. Open the downloaded nupkg file with any archiving program (winrar or 7zip). You will find the dll in lib\net48 folder.

Interesting. We had a different issue with Cumulative Update Version 20H2 where it locked a bunch of DLLs from custom packages and would crash Dynamo. We only had to manually unlock them, but maybe some of that was due to already updating GregRevitAuth.

Good to know for reference anyway.

btw, the Revit team is aware of this issue and it should be resolved in an update, I just wanted to make sure that was clear.