Set Type Parameter

I’m working with Archi-lab_Grimshaw and it seems like “Set Type Parameter” Node isn’t working.

Any ideas of what I might be doing wrong?

Get works fine!

1 Like

Are you sure the parameter is a number? and not a string?

I tried both

Is it working fine for you?

Well, I haven’t used @Konrad_K_Sobon nodes for this unfortunately, but I’ve used the Rhythm node SetParameterByName and it works fine.

7 Likes

Thanks!

the archi-lab node is expecting a list if I am not mistaken.

Why not use OOTB-nodes? (Out of the box, nodes already included in Dynamo)

5 Likes

Pretty much what my Rhythm one does. :smile:

2 Likes

This node only handles Instance Parameters.

It handles Type Parameters just fine, if you use the Element.Type node, like Einar showed :slight_smile:

If “Note d’identification” is the Type Comment Parameter, then it takes a string and not a number. Just FYI :wink:

What about set?

I tried this and it works. Great Script Martin_Spence1. Thanks, but I am confused.
Why you select an Element one by one instead o whole Family Type?
In another thread I asked for a node like yours but for change a “Type Comment” of a whole Family Type.
Maybe you know how. Thanks again

Hi, I am having trouble with the same topic, only that I want to set a type parameter which works with intervals. To make it clearer: I have several wall types and I want to set the “Wrapping at inserts” parameter to “Both”, but as it has a drop down for you to choose, when I look for the parameter value, it retrieves a number from 0 to 3 (options are none, interior, exterior, both -something like that) and when I want to set the value to 3 for example, all nodes that I have found don´t accept numbers for intervals as parameter values to set.

Hi All,

There is a Video showing how to set type parameter value into element types.

Dynamo - Set Type Parameter Value into Element Types

Hope it it helpful!