Sequense within Dynamo? UI.MultipleInputForm++


I’m using and loving your UI node. It realy works and is just what the docter ordered! :smile::+1:
Only know I’m walking into a problem…of sorts.
I need the user to specify the location of an excel file AND the user must be presented with a dropdown box from data within that file. But this isn’t possible within the same UI.

Or is my understanding of Dynamo not complete and is Dynamo calculating all connections at the same time and only stopts when it doesn’t have a value…and continious when it has “found” (via the UI) a value?

1 Like

Very glad you find it usefull ! :slight_smile: :slight_smile:
I understand your query. One possible workaround is to use two UI.MultipleInputForm, like in the workflow at the end of this article :

the first form prompts user to select excel file, then the “was ran” output is used as a toggle to open the second Form which will display the content of the excell file.

Let me know if it’s working for you, I’m realy interested :slight_smile:

1 Like

Thanks for the link.
I’ll dive right into it. I’ll let you know as soon as I get it to work. (Might be tomorrow though…it’s getting toward the end of the workingday here in the Netherlands :innocent:)

Hi @Mostafa_El_Ayoubi,

Just tryed your UI++. And at first it didn’t work right. I used 2 UI++ nodes to make the script like in the last example on your webpage. But that returned me the wrong value’s/list. After replacing the second UI++ for the “standard” UI it worked like a charm! Now I first get a pop-up asking me for the location of the excel file. And after setting that value I’m getting a pop-up asking for the rest of the input! :+1:

1 Like

Nice! :slight_smile:
Could you please show me the error you get with UI.MultipleInputForm++ ? I’m working on the next release, the main focus will be on enhancing that node, I’d like to fix it if there’s a bug …

Here you go! The user pop-up form is not correct when using the UI++

UI++ -> UI = works

UI++ -> UI++ = FAULTY

Alright got it ! UI.MultipleInputForm++ handles dropdown inputs differently that’s why it doesn’t behave as expected. My next post will be about that.
Thanks for your feedback, much apreciated.

1 Like

Hi @Mostafa_El_Ayoubi,

To be honest…I like the combination UI++ -> UI better then the latest update!
I got more nodes and I can’t get it to work!
That is mostly part of me not understanding all the Dynamo nodes there are.
I’m stuck at the drop-down part. I have a list of family types and need to confert that to a string so it can go into the “keys” port. And if I’m correct the normal Family types list (not being a string) needs to go into the “Values” port?

Also I get the output “Function” at the UI++ nodes and that can’t be handled with the nodes that follow.

Hi @Mike_Wellink,

you’re doing almost everything right. I believe that the problem here is that you uploaded the package , which uploaded the nodes that were already in use in your existing workflow. I had the same issue . To solve that, just replace the UI.MultileInputForm++ nodes you have in your worklow with new ones (really new ones, not copy pasted ones).

And yes, “keys” is the list of family types names and “values” the matching list of family types.

UI.MultipleInputForm still works the same as it used to.

I’d be happy to help you if you drop your .dyn file .

Your right. I updated the package and used the nodes instead of making new nodes.
I made new node and the script works better…but the second pop-up doesn’t show up.
Probebly because the drop-down isn’t correct.
do you know what node I must use to make a string out of a list?

FamilyType.Name (or actually any “XXX.Name” node) should do the job :


It’s working…IT’S WORKING!!! :+1:
:flushed::flushed::flushed::flushed:…Why didn’t I thought of that!

1 Like

Great :slight_smile:
UI.MultipleInputForm++ requires a little more work but I think it’s worth it

1 Like

I totally agree!
With a UI like this even Revit users that don’t know Dynamo still can use it’s awesome power!

1 Like

Hi Mostafa,

I downloaded the Data-Shapes package today but can’t get it worked.
With every input type, like dropdow, textbox or boolean, no input screen appears in Revit.
What am I doing wrong?

I agree these are fantastic addition to Dynamo - I’d say a game changing addition really. In trying to generate listboxes to select multiple elements I’ve run into an issue - per your request here is the screenshot.

Hope that uploads properly.



Hi @thurevit3 ,

so far you’re not doing anything whrong :slight_smile: you just need to make a list of the three input you created and feed it to UI.MulitpleInputForm++ like this :

Hi @scott.lind , really glad that you find those nodes helpful!
So far, you have to use a UI.DropDown Data node for each input you create :

But it actually would make a lot of sens to use it the way to tried to. I’m going to work on it . I’ll keep you posted! :slight_smile:

1 Like

Thanks for the super fast response Mostafa. I really can’t say enough good things about your development. I have non-Dynamo users requesting development of tools that until you created this were not really feasible. I plugged my real lists (auto generated) in in the proper format you showed me and it works perfect. Did the same with the listview node to allow multiple selections and also worked flawlessly (Revit 2017.1).

1 Like