MultipleInputForm++ & Code Block error

Hey there. I’m trying to create a UI with Data-Shapes to place all Views on Sheets and as demonstrated in the image, the MultipleInputForm++ is not working and it gives empty list despite having the list properly working prior to that and following it, the Code Block gives an error saying: “Index was out of range. If non-negative must be less than the size of the list.” Would anyone know what the problem is with this node? (I’m using Revit 2022)

Does the node all familys of category need a toggle input?

No, by default it is considered as “Yes” so you don’t need to do anything with that unless you want to set it as “No”; in that case you can set a node for it

You need the node Image Data between the filepath and the logo input.
After that you need to set the image data in the list.create as well.


I tried that but still not working. I don’t you why the MultipleInputForm++ is not working. I have another script made with it and it works perfectly.

Your MultipleInputForm++ is not returning any selected values from the Windows pop-up form. Are you sure you selected any inputs?

It’s hard to help you whilst only seeing half of the nodes, but perhaps a List.Join would solve the issue (as a replacement for the List Create node)

do not re-run the script after closing the form.
should reload the script or toggle false to run, then toggle true to run again.

Here it is the Inputs for MultipleInputForm++ I’ve created.

Not working either in that way. I just tried it

Check the inputs into the input node after you have run it, to see if there is values going into them etc.

As a try unhook the input node that receives 3d views while also reducing the list.create node by one value. If my memory is right, dynamo does not handle 3d views very well and may be causing issues, worth a try.

Well I also unhooked the 3D Nodes but still it is not working. The UI Window will appear as demonstrated in the following image but there are no buttons and values there despite the fact that I defined them.

Have you tried using List Join instead of List Create?

Also what happens when you only use one “Input” node as input, circumventing the List Create node altogether.

So the UI is working just not displaying any data that is extracted from revit. Just because you have defined them does not mean you will be getting anything check these are outputting information.

Eg you ask it to get a specific title block with a specific name, though if it cannot find it then it will be a “Empty List”

If they are giving empty list or null values then that will be your issue, then you need to check they are named correctly or the project has the elements you are after as it may not do.