Data-Shapes "Ui.MultipleInputForm++" doesn't work

Hello everybody,

i’m trying to make it work the UI.MultipleIntupForm++ of the Data-Shapes package within the 1.3.4 version of Dynamo on Revit 2019.

I’ve tried to add the drop down and the list view inputs as explained on their website https://data-shapes.io/2016/12/13/ui-multipleinputform/
The window supposed to appear doesn’t pop up and the result of the node are all “null” values. I’ve tried several things like:

  • uninstall/reinstall the package
  • install previous versions of the package (currently i am running the 2017.4.120)
  • uninstall all the plugins on Revit
    but nothing works.!

I’ve the same problem with the 2.0 version of Dynamo and with Revit 2018.

Im desperate, any help would be precious!

Thank you so much
Letizia

Try adding a List.Create to collect the values being used in the Inputs input.

1 Like

Like this. All of the input need to feed the List.Create node.

1 Like

Thanks guys, I’ve tried but unfortunately it didn’t work… same problem. Any other idea?

Would you please post another image of your current graph with the previews expanded?

Also, are you getting the Drop-down / listview to popup, or not even that?

Here is the result when i add the node List.Create:

The result is the same: all “null” values as outputs and the pop-up window doesn’t show up… :frowning:

Instead, the simple “UI.MultipleInputForm” of the same package works very well:

I don’t know what i am doing wrong :frowning:

If you are running a 2017.4.120 version of DataShapes then that is most likely your cause. There has been literally 50 updates to the package since then and the current version is 2021.2.5. I’d try installing the current version and see if that doesn’t help. It should work on 1.3 and 2.0 I believe.

3 Likes

Hi @Paslet87 ,
@SeanP is right updating will most likely fix your issue . I don’t think the latest version will work for 1.3 though. I’d recommand version 2018.12.1. After that it’s all for 2.X .

1 Like

Many thanks @Mostafa_El_Ayoubi, i have installed the 2018.12.1 version of the package and it did work! @SeanP i’ve tried to install the 2021.2.5 version but it is just for the 2.0 version of Dynamo. I’ve also update the Dynamo version from 1.3.3 to 1.3.4, maybe it was part of the problem.

Thanks to all, guys!

2 Likes