Revit to Excel - MEP Parameters

Following @Kulkul’s URL solution I applied it to all the other Type parameters

With the following results:

  • Greyed out parameters are “read-only”
  • Other parameters that don’t work “The parameter’s storage type is not a string”

MEP Parameters

Direct input also works for MEP Parameters but needs to be converted before being pushed to Revit. I still haven’t figured out how to convert them back with factors or other nodes.

I seperated the problems to seperate the solutions and facilitate Kudos and Solution Marks.

Hello Jonathan,

The problems pertaining to the MEP parameters is a question of finding out the right conversions for your units and feeding the parameters the correct object type (usually doubles or integers instead of strings). You could also use one of the custom nodes in the MEPover package that will let you set your parameters as project units or as strings.

The read only error you are getting seems to be correct as most of those parameters are grayed out, meaning they can’t be changed directly.

For both of the above problems I would suggest trying to set a single parameter at a time and then see what error you’ll get and try to solve that single error. Rinse and repeat for every other parameter that gives you an error.

HI @T_Pover,
I found the idea of finding the conversion factor by input the Value “1” and working from there on another post also (i’ll try to find it again to give kudos).

It works with direct values using Code Blocks, but doesn’t when I try to plug my list Values directly

After “string from object” node it gives an error message as follows

That’s probably because you’ve converted your input to string with the String from Object node. At that point it’s a string and trying to divide it by some value won’t work. The output of your code block is probably a list of nulls.
You should first try to find out what kind of unit revit expects as input. You can do that like this:

Look up the pressure_Loss parameter in that list and its corresponding storagetype. If it’s a double or integer than you have to feed the input of you Setparameter node a numeric value.

I checked with the above nodes and Pressure Loss or Flow Type parameters were not there so I used an Addin from a previous post with @Kulkul to look deeper in the object and found this.

The storage type for Pressure_Loss is “Double”

Since double is a numeric value, I found a “string to number” node and tried it

It worked on 3/4 of the the family Types with no error messages to explain 4 In but only 3 Out.

That’s great, part 1 is solved :slight_smile:
Are you sure you’re inputting 4 element types and not 3?

1 Like

My bad, since I was seeing 4 elements in my excel reading side of the script it never occured to look at a the Model Element selecting side to make sure I had the 4 types…

Selecting Side:

Output: