Revit 2019.2 - Crashes instantly when opening Dynamo 2.0.2 files

Has anyone else experienced this? I just upgraded to 2019.2 this morning and when I try to open .dyn files, it usually crashes instantly. Only my very basic .dyn files open so I’m assuming this has something to do with the packages not working with the new 2019.2 update?

3 Likes

Maybe - can you send your Dynamo logs and Revit journals from a crashed session? After grabbing them try removing all packages (just move the contents of your package directory to a new path)

Not sure what you mean by grabbing the Dynamo logs and Revit journals, sorry. I’ve uninstalled all my packages and am working my way back through reinstalling them. I’ll update this but so far, bimorphNodes crashed my Revit/Dynamo session right when it was downloaded.

EDIT: After reinstalling all the packages I still have the same issue. And I have double checked, scripts still work fine in Revit 2017, which is the latest version I have other than 2019.2.

Without Bimorph does the issue persist?
FYI @Thomas_Mahon

Yes, it still crashes even when I open a .dyn file that doesn’t have any Bimorph nodes in it. Here’s the list of packages I have installed: All of which worked fine before the upgrade to Revit 2019.2.

Please grab your Revit journals and Dynamo logs (located in %appdata%\roaming\Dynamo\DynamoVersion\DynamoBuild\logs) for review.

After that use this .dyn (run it via Dynamo sandbox) to check what packages may be in the wrong dynamo build.
What Package Engine.dyn (40.5 KB)

@JacobSmall if you’re aware of an issue here (with BimorphNodes) let me know as I’m releasing the next update within a few weeks and can add any updates. As far as I’m aware it should work fine with Revit 2019.

Not aware of a specific issue for your package at this moment, but wanted to make sure you were watching incase it comes up. :slight_smile:

Err OK. Not quite sure why you’re singling BimorphNodes out, but whatever. Its built on 2017 Revit API so should be fine (Autodesks 3 year compatibility span), Dynamo 1.2 ProtoGeometry / Services, etc, and has wrapper classes build on the Revit 2016 and 2018 API for a handful of methods requiring backwards and forwards compatibility. None of this will affect its operation in Revit 2019 however since any methods built on the older API’s can only execute if the user is running older versions of Revit.

1 Like

I think it’s a case of a bigger issue with the system setup, not necessarily tied to your work. :slight_smile:

Looks like OPs updated his comments after I said that. The joys of the edit button! I think you’re right, sounds like a local environment issue.

2 Likes

So here is a log from today where my session did not crash, but I got 10 warning notifications. Also, after uninstalling and then reinstalling the packages my packages folder is empty so that “What Package Engine.dyn” doesn’t do anything for me. Does it make any sense that my 2.0 packages folder is empty? That is confusing to me.

Log attached - ignore the lines about RLF packages not existing.

dynamoLog_76fb2e55-5027-4490-b229-365a64981915.txt (44.0 KB)

If you have any nodes from any package showing in your library then you may be looking at the wrong packages folder - check manage node and package paths in the settings menu to see where they are being pulled from.

If you have no packages in Dynamo (and therefore basically no custom nodes), then it’s likely a Revit add-in that is triggering the issue. Try uninstalling all Revt add-ins and then see if that solves the problem.

Ah I see… When I reinstalled the packages they were going to a different folder. I’ll have to look into my add-ins as well. It’s been stable today though. Maybe I just needed a hard reboot after reinstalling the packages.

Edit: So if I’m seeing that some packages are made for version 1.3, but they run fine in 2.0 in my experience is there going to be any issue there? Spring nodes for example is one I use a lot and works well for me, but it’s only updated for 1.3. On github it looks like the next version will be for 2.0.

Springs should be fine. Can’t speak to all of them though.

Are all packages in one location and is it local to your C drive?

They’re all now on my onedrive actually. I’m planning on removing those today and putting them back on my C drive.

1 Like

@JacobSmall

Trying to work in Dynamo again today and I’m having an issue with it crashing again. It crashes anytime I open a .DYN file. If I open a new file and build a new .DYN file, it doesn’t crash.

Background: I removed all the packages from my onedrive and reinstalled them onto my C drive. I used “Manage node and package paths” to remove the path to my onedrive.

Can you take a look at this log and see if there is anything in there that points to something I’ve set up incorrectly? This is a log from when I tried to directly open a .DYN file and Dynamo crashed my Revit session. It looks like it’s still trying to open from my onedrive even though I’ve removed it from the node and package paths:
dynamoLog_df5754c1-f4fe-4bda-9356-f763061f8e7f.txt (6.4 KB)

I am seeing a bunch of Failed to delete package directory at "C:\Users\bac\OneDrive... which you’ll likely want to manually delete as noted in the log. Shouldn’t be causing a crash though. If you remove all packages is it stable?

Since Dynamo is crashing the Revit session it may actually be a Revit issue or related to another system configuration. Restart your cpu, start a new Revit session, create new Revit project, save it, open Dynamo, open a dyn file, let it crash Revit and everything hosted on top of it, submit the CER, and then grab all of the following:

  1. The DYN file.
  2. The dynamo log.
  3. The Revit journal.
  4. The saved .rvt file.
  5. The CER report number and the email you sent it from.

Start a new support case with one of my colleagues in support directly as you would if AutoCAD or Revit just crashed any time you used a feature of the product (which Dynamo is in this perspective).

Let us know when they find the issue so others can resolve similar issues on their own.

Thank you for the recommendation. I’ll do this later today when I get a little bit of time. The only thing is that the crash doesn’t bring up an error report to send like it usually would with a Revit crash. I’m thinking I may just directly reach out with the other items you mentioned though. After it all gets (hopefully) resolved, I’ll report back here. It only happens in Revit 2019.2, not 2017 so it may be a bug.

What Dynamo version are you using in 2017?