Corrupt DYN file, crashes Revit on opening


#1

Hi all,

I’m having difficulty opening a Dynamo graph which recently crashed. The file has been developed in Dynamo 2.0.1 and running on Revit 2018.3. A colleague has managed to open the file in Dynamo 2.0.1 using Revit 2019.1, but I cannot replicate this on my machine. I’m guessing a package or custom node I have downloaded maybe corrupt, but I cannot open / isolate the issue.

Has anyone else come across a similar issue or could take a look at the .dyn please?

CORRUPT .DYN FILE

I’m relatively new to Dynamo but have been using this forum to gain a greater understanding for some time now, this forum has been an invaluable resource for info. Thanks for any help.


#2

I think I have the same issue with some scripts.

I use a trick to edit those scripts. I open the Dynamo player and instead of running the script I edit it, so I can open the script.

Don’t know why that happen

Cheers

Manel


#3

Thanks Manel - just tried this trick and whilst Revit did not crash and close. Dynamo returned the following error

DynamoError


#4

Are you using dynamo 2.0? I get a similar error when I try to open a 2.0 file with Dynamo 1.3

Cheers

Manel


#5

Hi,

You can check this thread :


#6

No - graph created in Dynamo 2.0.1 and attempting to open in 2.0.1. I also get the error message if I try to open the graph in Dynamo 1.3. :face_with_monocle:

The bizarre thing is, that I can open the graph on another machine that has the same Dynamo and Revit builds installed.

I’m guessing it may be a package that’s not compatible with Dynamo 2.0 that’s causing the error.


#7

Thanks Mellouze - think my comment below agrees with the error in your thread.

I may have redraw the graph from a clean install of Dynamo.


#8

Hi there,
I’ve downloaded the script and I can’t open it. my revit also chashed.

I used my trick and I can open it:

I used Dynamo player and edit the script. To use Dynamo player properly, before use it you have to open Dynamo, select Dynamo 2.0, close it and open Dynamo player, then select the script and edit it.

Cheers.

Manel


#9

Thanks for your reply again Manel,

I tried to open using Dynamo player as you suggested but still couldn’t open / replicate your result.

I’ve removed and reinstalled some packages, then recreated the graph in Dynamo 2.0 from scratch and it appears to be working fine. I can only think a couple of the nodes I had used were not updated for Dynamo 2.0.

Thanks for all your help.