Polycurve is not getting smooth

I want to make a smooth polycurve by points list.

On this photo polycurve should go through every point and look like an 3D arc. Should be smooth.
I know few scripts to generate it but the result is not satisfying me. Maybe it’s a matter of settings, render or… i don’t know.
Anyway please show me the right solution of this issue.


try a NurbsCurve.ByPoints node

But I tried. You can see on photo. Also there is few more, and all of them gives unsatisfied effect.

“This” is my intersection.

Something went wrong, definitely :frowning:

Post your excel file and dyn so that someone can help you out.
Best way to do this when you are a new user is send it to yourself via wetransfer and post the link here.
Or find another file sharing service like dropbox.

Marcel, thank you for your response.
Here is the link with files:

Anyway, I have abandoned this way of work.
So the topic can be closed.

Just FYI, you would want to use NurbsCurve.ByControlPoints to get a smooth curve.

Another FYI: Your data is too large to readily process - the values at medium geometry wind up too close to generate points, and the values at extra large geometry loose the precision which make them valuable. This is why you’re getting ‘bad’ curves at all scales. Shifting them closer to the origin by subtracting the minimum value from the list, then building the curves should resolve this. You’ll have to shift stuff back to the project base point when done (assuming that matters to you).

Not shifting them will eventually result in this warning: Warning:

Your inputs lie outside of the allowable modeling range, consider choosing the Extra Large setting with a modeling range between 1 and 100,000,000 from the “Settings => Geometry Working Range” dialog

This is Dynamo telling you that you’re asking it to deal with too many numbers - it has a 10 digit working range - beyond that and you lose data on one side of the decimal or the other. The nurbs curves made at this scale (no mater what value you work with) are going to be jumpy - literally.

Changing the geometry scaling will resolve this to some degree, but you’re going to want to move things to the origin eventually. I’d question the accuracy of these values in any case. If you’re actually in meters, you’re currently drawing at values 8,584,513m away from the origin - or 3/4 of the circumference of the earth. If you’re in feet it’s better at 3/8 of the radius of the earth, but still well outside a reasonable measurement tolerance.


Looks fantastic! Thanks a lot.
Can be this solution implemented into Civil3D+Dynamo combination? With the same model?
I saw you replied to my other topic: Civil3D into Dynamo. Unable to create Line. Points are likely coincident, and would be great if it works on it too.

Thank you again!

It should (I need to reinstall C3D2020 tonight but if I have time I can test in the morning).

The big takeaway here is your coordinate system needs to be localized - reintroduce the transform to your project base point. :slight_smile:

1 Like

Did you found out is my issue can be solved like you did with the other one?

What issue? I’m a bit lost here.

I thought you checked your solution from this topic to another one, very similar but with importing feature lines from Civil3D model and “smoothing” it.

Did you try shifting the data points to the origin?

I tried for both, but for example with stand alone Dynamo (data from excel) it works. Not for Civil+Dynamo :confused:

Ok, mark a solution here and we can discuss in your other topic.