Excel.ReadFromFile failing with Excel2016

excel

#1

We recently upgraded the Office Suite, and now this node fails, I assume it’s related.

Excel opens when the script runs, but it does not open the excel file. The error note in Dynamo reads “Warning: Excel.ReadFromFile operation failed. File path not found.”

Things I have already tried:

  • It fails with the excel file on a mapped drive, or a local drive
  • It fails with *.xls, *.xlxs and *.csv
  • It fails with, and without, the File.FromPath node

If relevant, this is Dynamo1.2.1.3083, running in Revit 2017.


Excel.ReadFromFile in Dynamo on Revit does not working
#2

On further testing, I found i was getting a similar error with reading text files, so I changed the path of the files from
C:\Users\cprettyman.CERAMI\Desktop\Dynamo Scripts
to
C:\Temp

and now its working, so I seem to have been wrong about where the problem was.

Does Dynamo1.2 have issues with paths that have spaces?


#3

Hi @cprettyman

May be you don’t have access to read files from Desktop folder or system folders. Check with your IT Support.


#4

The script itself is sitting in the same desktop folder. I’ll check with IT to see if they somehow limited access to desktop folders from applications, but I doubt they would restricted it so that Dynamo could open the script, but not the excel file


#5

I’ve had a similar issue with the excel nodes. I too thought it was the spaces as it seemed to work when I moved the data file to another location that didn’t have spaces in the folder name.


#6

Same issue here. A file location with spaces in the folder name does work, a mapped drive results in a failed Excel.ReadFromFile. Also a direct approach (for instance: \\Networkfolder\etcetera\ doesn’t work either.


#7

@Arjan Is your excel open? Make sure you closed before reading.


#8

I have the same issue. Using a path without spaces doesn’t work either.
Started after installing Office 2016. I will try installing the 64bit package and see if that resolves it.


#9

After a bunch of testing, I finally concluded that this was unrelated to the version of excel I was using. Instead, it seems to be related to file location. It reads local files fine, but cannot read anything on a network path.

Charles Prettyman
Senior Associate
[cid:image85128b.JPG@fe76e06e.4a9257cd]
Consultants in Acoustics, AV, IT & Security

404 Fifth Avenue New York NY 10018
D 212 370 5049 C 646 637 5458
ceramiassociates.comhttp://www.ceramiassociates.com | Twitterhttps://twitter.com/ceramiassoc | Linkedinhttp://www.linkedin.com/company/cerami-&-associates | Instagramhttps://www.instagram.com/ceramiassoc/


#10

@cprettyman, I had issues with long file paths in earlier version of Dynamo, since upgrading to 1.3.0 this seems to have been resolved.
Timon


#11

I am still running into this issue with both the dyn file and the excel file located on my desktop. I even tried saving the excel file down to 2003 .xls format and still no dice. I don’t think it is a location or format issue at this point. I am not sure what it might be. I am using Dynamo version 1.3.2. When I look at the Notifications I am seeing about a dozen of System.IO.FileLoadException warnings


#12

I’ve got the same problem. my script suddenly stop working. Pls help!


#13

I have same problem at WIN 10, Revit 2018.2, Dynamo 1.3, Excel 2016.


#14

and also at Win7, Revit 2018.2, Dynamo 1.3, Excel 2010.


#15

We had issues when upgrading our Office package, we installed 64 bit (x64) but realised Dynamo would only work with 32 bit (x86) version of office. Not sure if this will help anyone, but thought i would share this regardless.


#16

I believe there is a bug in the file path node - please use a string instead. This should be fixed in dynamo 2.x - alternatively someone could provide a ui node in a package that fixes the issue as a workaround, or perhaps use something like data shapes (if that has a file path node).


#17

@Daniel_Woodcock1 - so you find that you cannot interact with x64 installs of excel? @Neal_Burnham fyi.
what error do you see?


#18

So I did update at Excel version 1712 and it does help. It is working !!! Thx for help.


#19

Hi @Michael_Kirschner2,

We found when upgrading our office suite that the OOTB excel nodes stopped working with the x64 install. We installed the x86 install and it was working fine. This wasn’t on just one machine, but several.

Do you know why this might be the case as it was puzzling as to why this was happening?

Cheers,
Dan


#20

@Neal_Burnham FYI