Excel.ReadFromFile failing with Excel2016

@Michael_Kirschner2 @Daniel_Woodcock1 Thanks for testing this: we are tracking it with QNTM-3434.

1 Like

Please see https://github.com/DynamoDS/DynamoRevit/issues/1950 for another potential root cause of our XL node issues: the switchable graphics adapter (again!).

1 Like

So as far as I have seen the entire feedback. So this issue is still not resolved rite??

In the link which you posted above - it explains about the graphics issue but even after performing the process. I still have the same problem (Screen shot below)

Hi, there is a diff between file and filepath…you can use file from path option to rectify this issue sir.
Thank you…

1 Like

@glokeshganapathy Thanks
But I dont understand your reply or Guess you didn’t understand what the question is may be.
Can you describe where should we used File from path?
And one more if you can see attached screenshot.

Warning from Excel.ReadFrom File says"Warning: One or more of the input types are not matching. Couldn’t find a version of ReadFromFile that takes arguments of type (string,string,bool)"


Have a look here:

Your excel node expects a string, that is not what you’re passing, try connecting the “file path” node directly to your excel node :slight_smile:

1 Like

@Jonathan.Olesen…Cheers…Excellent explanation…(Attached Image No.1)

But the problem happens Only when I connect the string node.Please have a look.

Now when I connect the string node , the error pops up.

Even if I use from File.From Path node, it works in Excel.WriteToFile.

I am breaking my head becoz of this simple node, I am not able to perform excel task in Revit.
I would really appreciate if this gets sorted out.
Some blog says" There is problem with ReadFrom File node itself where Dynamo guys didn’t fix this issue".
Thanks @Jonathan.Olesen

Just because I am curious, can you try to use a code block with a string with the name of your sheet? :slight_smile: using quotation marks is what makes a string in code block :slight_smile: e.g. “sheet 1”

1 Like

@Jonathan.Olesen Yep Tried that one too long time before. No luck
Pls see below.

What error does the node now indicates ?

Also, probably just a dumb question, but does a sheet with such a name (Test_01) exists in Book1.xlsx ?

1 Like

Thanks @mellouze
May be I can attach the file directly for you guys to check :grinning:
ReadfromExcel.dyn (4.5 KB)
Book1.xlsx (8.0 KB)

Just add the File From Path node :slight_smile:

Edit : I am on Dynamo 2.0.1 if that is of any help


1 Like

Yo @mellouze
Seriously Amazing dude!!! Awesome!!!:grin::grin::grin::grin::grin::grin::grin::grin::grin::grin::grin:

It worked !!!

1 Like

@glokeshganapathy Thanks for the comment. What you said was perfectly true…It works…
Thanks :grinning::grinning::grinning::grinning::grinning: