Excel.ReadFromFile operation fails

The operation fails for some unknown reason. Importing the same file as a CSV works; however, I can’t use this workaround because some of the cells I need to import contain commas.

I am working with Dynamo 0.8.0.950 and Microsoft Excel 2007

Dynamo Problem

 

I’ve had the same problem when dealing with Excel files not saved on the local machine. Put the Excel file on your Desktop and I bet it will work.

Thanks for the quick response. I tried moving it to my desktop but unfortunately I’m getting the same error.

 

This is my excel file.

Dynamo Problem 2

EDIT: So I guess even although I moved it to my “desktop” my entire office works in a VM environment so it still isn’t a ‘local’ machine really. I’m not sure if this would affect the issue but I don’t really have a workaround as all of the Revit licenses in my firm are in a virtual environment.

To test whether that is the issue, you could try saving the Excel file as a CSV, then reading the CSV file into Dynamo instead of the Excel file.

I am seeing the exact same problem. Last night I was running Dynamo via Remote Desktop Connection, this morning I tried on my local machine with the XLS file saved to the desktop, still no luck. I have also tried versions 7.5 and 8.1.

Excel.ReadFromFile not working

Add File.FromPath node. Cheers!!!

 

Read From File

Luke and Kyle I was having the same issue previously then i updated my excel 2007 version to Excel version 2013 it solved the issue.:-)

Bummer, I have Excel 2010… Not sure if my company is planning to upgrade to 2013 in the near future, too bad the node doesn’t like older versions.

Thanks Kulkul Kulkul, inserting the File.FromPath node did the trick! Looks like I can stick with Excel 2010.

I am having the exact same issue. I have excel 2010 and Revit versions 2017 & 2019.
I have saved the excel file to my desk top along with the Revit file and have also added the node File from Path.
I still get a fail error.
Any further ideas?