File Path Not Reading

I’m having a hard time with the File Path node. It seems to not be working on a specific DYN file. If I start a new DYN file then it works just fine but not in the specific file. Even if I copy all the nodes into a blank file it still won’t work. The images below show the File Path node working in a blank document but not in the specific DYN file. Any ideas?WorkingNot working

This may be a network issue. What is the drive location for the file? Share your .dyn in its entirety and I can weigh in more.

Hi, @B_Derrick

Are there any spaces in the file path?
This might be the culprit.

Marcel

1 Like

Thanks for the replies @JacobSmall and @Marcel_Rijsmus.
I’ve tried different Excel files saved in different locations, the latest on my desktop. There are no spaces in the file or file path (but that error was fixed in the latest release of Dynamo anyway). Also, notice that the file is being read in a blank DYN file with the exact same nodes. Pretty strange. To make it even stranger, the non-functioning DYN file was working a few days ago but something has happened that has caused it to break.
Below is the file, you shouldn’t need the Excel file since I can’t read any files with it.
TestFile.dyn (218.0 KB)

I just got a similar issue with Revit 2020. Everything was fine, then File Path died. Pasting into new DYN worked. But then I pasted the whole graph into a new DYN and File Path was dead again.