Excel.ReadFrom File not finding the File Path

excel

#1

I am having issues with my Dynamo-Excel routine since I installed Dynamo 1.0.0.
Any extraction of data from a project through Dynamo into Excel works without any problem.
However, when data needs to be read from Excel into Dynamo, I get the error as shown in the image below:


I have already deleted the node and recreated again, but without any success.
Would there be any connection with perhaps an issue between MS Office 32 bit and Dynamo?


#2

Hi,
Try copying excel file to another location. Create new folder in C drive and paste your file there and see if it works. Good luck!


#4

Hi Kulkul. I’ve done that already but it did not work. Thank you anyway.


#5

What version of Excel do you have and did you previously have an older version installed? It appears that upgrading/uninstalling/cleaning out Office 2007 leaves breadcrumbs that we do not deal with properly when attempting to use the upgraded 2010 and later version.


#6

Hi Zach. Thank you very much for getting back to me. I believe we have always been running the 2010 version, but I have noticed that a compatibility window pops out when I hit the save button in Excel. I will check tomorrow at the office and I will let you know. Thank you again.


#7

Good morning Zach. I have asked in the office and the IT department assured me that there hasn’t been any updates and that we have been using Office 2010 for a very long time.

So, we have unistalled all Dynamo versions from my PC, and reinstalled only 0.9.2 and 1.0.1 but I still cannot make the Excel.ReadFromFile node work. It keeps on stating that the File Path was not found, and opens Excel without any file. It does not matter where the Excel file is located. The same issue keeps on showing up.

While installing the 1.0.1 and the 0.9.2 versions, using the IT admin’s credential, a message popped out on the screen, which I could not make a screen shot because it was remotely done, and it stated that the IT did not have rights to create a new Key for the software (HKEY Error 5). So, the IT staff had to use another type of admin credentials in order to be able to make the installation. Would this have any connection with the issue that I am having?

Just as a test, I have also included 3 extra nodes to test if they would read the File Path. The nodes are the following: ReadExcel (by Hot Gear), Excel.GetExcelWorksheetData (by LunchBox) and Excel.GetExcelWorksheetDataByRange (by LunchBox). They all find the File Path but generate Empty Lists or errors (crashes) Please, see images below:

The first one is just to show that the Excel file contains data and it is not empty.





I have just followed a colleagues suggestion which was to start a new file and check if the first sequence to read from Excel would work, and it did. It is quite funny to see the “same” node coexisting in the same file but only the ones created in the latest version work. I will probably need to do the same with the other nodes that are not working as well. Please, see images below:



#8

Hi,

Is it possible to put here your dummy excel file?


#9

HI Kulkul. I believe the solution has been just found. It is not the Excel file but the nodes from version 0.9.1 not being converted when the file is read in the new version. Thank you for interest in my issue. I will let you know if this solution will work to all non working nodes. Thanks again.


#10

Good Luck!:+1:


#11

Thank you!


#12

Hello @Haley_Jovi_Cazarini,

So you mean if you open the file which has Excel.Read node created in 0.9.1, doesn’t work with 1.0.0?

Meantime I will try this scenario at my end.

Thanks for reporting and sorry for the inconvenience.

Thanks,
Ritesh


#13

Hello @Haley_Jovi_Cazarini,

I have created the same graph to read the excel data on 0.9.1 build and then opened the same file on 1.0.0 and it worked properly. I didn’t get any error for the file path.

Thanks,
Ritesh


#14

Hi Ritesh. As you can see in the image I posted before the last one, the same “Excel.ReadFromFile” node, where the top one was created in a new file in version 1.0.1 and the second in the 0.9.1, behaves differently. The top one reads the File Path, the lower one gives the errors.

I was hoping that when substituting all nodes that are giving errors for the ones from version 1.0.1. would solve the issue but I was wrong. I will need Konrad’s help again to see why more nodes in the routine are not working. Thank you anyway for testing this for me.

Just a question, would the Revit version or Service pack have any impact in Dynamo’s performance?

I thank you beforehand for your help and attention. Regards, Haley


#15

Hello @Haley_Jovi_Cazarini,

I tried it on 1.0.0 and not on 1.0.1 as I saw you mentioned that version in your first post.

I will try on 1.0.1 and will get back to you.

Thanks,
Ritesh


#16

Hi Ritesh and Zach. I found an issue with the “List.CountOccurrancies” node created by Clockwork. The Code Block formula inside of their node is referring to GroupByKey command, and the output was Function twice. I am not sure the Code Block was supposed to be like that. So, I have changed to GroupByFunction and that part of the routine is working again. Please, see images below.


#17

Is it possible for us to remote into your system?


#18

Hi Neal. Thank you so much for getting back to me and for the offer. I need to check the company’s procedure so that we can organise the remoting session with you. I will let you know as soon as possible. Thank you again. Kind regards, Haley.


#19

Hi Neal. Could you please explain me the process used by Autodesk to remote to others’ computers? What software do you use? I am just trying to get more info on that so that I am ready to answer this questions if I am asked by the IT department.
I thank you once again for your support. Kind regards, Haley.


#20

I was originally running Win8.1 Dynamo 0.9 with Office 2010. We’ve upgraded PCs last week, and moved to Win 10, Dynamo 1.0 and Office 2016. The existing scripts reading and writing to excel work without issue for me. One thing I’ve noticed when modifying the “Master” scripts (Each version points to a specific file for each project.) that 1.0 doesn’t seem to retain the path very well if you copy/paste the .DYN file to and from a network location. 0.9 had no issue with this. After the .DYN file has been copied, I need to open it and repath the File Path each time again manually and it works.

(Dynamo converts the path to a UNC path instead now. I think this is where it’s failing, as the long path is written out until you redirect it back to the same exact file, then it becomes a UNC. (…\etc.)


#21

Hi Jason. Thank you very much for that. I have “re-pathed” the file and it did not work. I only managed to have it reading the file again when I have created a fresh file with the initial node steps and pasted into my old file, and then it managed to read it. Since then, it has been reading the Excel file. I just need to make it ready my parameters, which seems to be the last step to have it working from my computer. Thank you again.