Drafting views to new family type

I have created a graph which was heavily inspired by the following post at :


In our firm we organize our drafting views by creating new drafting view family types which match the sheet names. Currently, I use the graph listed in that post (slightly modified to match our firms detail naming convention) to rename our drafting views and then move them manually to the drafting view family types in the project browser. I want to automate this more. I created a graph that will duplicate our typical drafting view family type and create new ones and name them based upon a modified string of the appended view titles generated prior but I can’t figure out how to move the drafting views to the newly created family types in dynamo. Im stuck, any help would be appreciated.


Try this:

1 Like

Thanks Kulkul. I used your approach and it works but only for one added drafting view family type name at a time. I will have many based upon different sheet names. Is there a way to do this with differently named family types from a list all at once? I can’t seem to figure one out.

Yes it is possible. I have tested for 2 drafting view family type name. See below:

1 Like

I know this thread is old so this is probably a long shot… What packages are you using to make this work? I have some Clockwork and Archi-lab packages that supposedly do the same things, but aren’t working correctly.

Hi @jason.markgraf

You need to show your complete graph with errors expanded. It will help others who is trying to help you. Read the forum guidelines.

Here is my graph:

Essentially what happens is that I have another script that renames our drafting views, and I’d like this one to sort them into view family types based on their names. I haven’t gotten to the bottom portion yet with the families based on the sheet names. I’ve tried the method you used above, but it doesn’t seem to have any effects. The view type family is created, but none of the views are moved to the corresponding family type. I don’t receive any errors when running the script, so I believe I may not have the correct custom nodes inserted. Thank you for any help you can provide!

I have narrowed down the issue to the FamilyType.Duplicate node. It’s outputting an empty list (see top right of graph) - anyone have any idea why that would be?

Look at your Element.Type list all has got same element id’s. Use “List.First Item” node to get one unique item from that list.

Got it, thank you - I missed that. That gets me all the way to the last node. I’m feeding the filtered list of views into the familyInstance input and the repeated item list from the List.OfRepeatedItem into the familyType input. I’m using the Clockwork FamilyInstance.SetType node, maybe that’s the issue. I tried the Archi-lab Change Family Type node, but that looks for a built-in parameter and I’m not sure I can call the drafting view type parameter, can I?