Certain packages not showing in Library

I have installed a number of packages on a network location, and changed the manage node and package paths to reflect their location, but only some of the installed packages show up. I have also tried uninstalling and reinstalling both Dynamo and the packages, as well as deleting out the local package directory when uninstalling. I also don’t have the option to unblock dll files. I’m on dynamo 1.2.1 and using revit 2016 and 2017, any thoughts on how to fix this issue?


ask IT to unblock the DLLs for you.

1 Like

Unfortunately that doesn’t seem to be the issue. We looked on the server and the IT guy still doesn’t have an option to unblock the dll files. I also tried unblocking the files on my computer and then copying the directory over to the network location, but the packages still aren’t showing up in the library. Any other thoughts?

So basically you might be running on a different version of Revit than one that any of this packages uses. For example i know that archi-lab is referencing 2016. That might make the package not show.

I’m having the same issue in both 2016 and 2017. The issue does seem to be related to the dll’s, as the common factor between all of the packages that aren’t visible is that they have dll files in the bin folder. The issue is only on a couple of our new computers, but even locally, if I try to install one of these packages, it doesn’t show up.

try removing a archilabUI_DynamoCustomization.dll from the bin folder. Let me know if that helps.

I’ve only got archilabUI.dll and Archi-lab_Grimshaw_DynamoCustomization.xml, but removing either of them didn’t change anything.

when you open Dynamo, do you have any notifications? On top of the screen, what does it say?

Not on the machines that are having issues seeing packages, I do have these 4 notifications on my machine.

that’s for Mandrill and the fact that Revit already loads some version of EO.WebBrowser. It shouldn’t cause issues. I have both packages and it works for me.

Thanks for your help, it turns out to have been a permission issue. I’m still not clear on why the permissions were working for the same account on older machines, but not the newer ones, but at least we’ve got it working now.