Installed Packages not showing after installation


#1

I’m having a similar problem Revit 2017 Dynamo 1.2.1.3083.
It can read my nodes in the root folder of the node path I put in but none of the packages. Packages are in folders under that folder.
The packages are listed when I go to Manage Packages, but don’t appear in the sidebar of nodes.
Uninstalling and reinstalling packages makes no difference.
Moving the node path to other locations makes no difference (I’ve tried Documents, local hard disk, network share location). I’ve checked permissions of folders.

Packages are a great idea, but only if they work.


Installed packages not showing
Installed packages not showing
#2

There is a problem with packages not loading. I have been writing with @Konrad_K_Sobon about this problem concerning Archi-Lab.Net. As I understand it, it could be the case that some coders are testing Dynamo 2.0 and have started to code their content for that version. It might be the case that this has an influence on loading the packages in current versions.

I have both Dynamo 1.3.0 standalone and Dynamo Studio 2017 installed. In the Dynamo Studio version I can not load Archi-Lab.Net, BimorphNodes (@Thomas_Mahon), Dynatools (@Cesare_Caoduro3), Beaker, and Rhythm (@john_pierson).


#3

Archi-labs is one of the packages that won’t load. The others are Clockwork and Lunchbox.


#4

Since yours is 1.2.1 there might even be more packages not loading… Try to list them all and their author if you can find them as user, then they will see the post.

Clockwork is @Andreas_Dieckmann and Lunchbox is @Nathan_Miller -> @Nathan_Miller1


#5

Dynatools is not built to work on Dynamo Studio…that’s why you can’t use it. Actually, most of the functionalities are “Revit related”…


#6

Isnt it a problem that packages cannot be loaded in both versions? I do understand the “most related to Revit” issue, but shouldnt Dynamo Studio be able to load all packages?

@Racel_Williams is there some kind of problem here? is it so that developers need to do something special for the Dynamo Studio version?

I am not that familiar with the Dynamo Studio version, cant really see how it is better than the standalone version…


#7

@Antony_Mcphee can you post the path to your packages? I had a similar issue and it was due to someone installing a second version of archilab, clockwork, and bakery (and all dependent packages) on a shared network location, effectively making dynamo try to add them to your browser twice which appears to be a no-go.

I resolved my issue by removing all installed packages from my dynamo version (felt naked), removing all package paths, closing dynamo, renaming every package path to ‘old packages’ and then opening dynamo and remapping to a new folder where I did clean installs of the versions we wanted.


#8

Did you check that the Core is the 1.3 instead of the 1.2 because that could be the cause of the problem.


#9

some old packages still work with the 1.2 core but in the 1.3 version of Studio the core is the 1.3. That could be a reason why the package is not working.


#10

I had the same problem and turns out that the uninstallation section of my dynamosettings.xml had the faultive package in it.
I removed them manually and it;s been ok for a while now


#11

I uninstalled all packages (some I had to delete manually).
Made sure all were deleted in Node folder.
Re-installed.
All installed.
Folders are there in node path.
But NO packages in sidebar, nor when I try and list contents.
However when I use ‘Show root directory’ it goes to the correct directory.

Path is:
\ridleyco.local\userdata\sydUserData\amcphee\Documents\SUPPORT\Dynamo\Nodes

What I don’t get is why can Dynamo find my nodes, but not the package nodes?


#12

the correct dyrectory should be this…
C:\Users\Elisabetta Caterina\AppData\Roaming\Dynamo\Dynamo Core\1.3\packages


#13

It might be so, that you must use full or absolute path and not unc paths
meaning C:\Users\something… not \\Users\something…


#14

@erfajo - The packages that contain zero-touch nodes that use the Revit API will fail to load at compile time if the Revit API is not present. That means that these packages will not show up in the library.

Depending on which client and version you use, the default folder for where the packages are installed to and called from vary:

  • For D4R, the default package folder is Users\username\AppData\Roaming\Dynamo\Dynamo Revit\D4R-version\packages
  • For Dynamo Studio, the default package folder is Users\username\AppData\Roaming\Dynamo\Dynamo Core\Dynamo Core version\packages

Please note that you can always add more paths for each client (D4R or Studio) to search for packages in, you can do this using the dialog found in Settings > Manage Node and Package Paths…

Lastly, just to clarify about version numbers, etc. If you have both Dynamo for Revit and Dynamo Studio installed on your machines, the following 3 items will be installed on your machine:

  • Autodesk Dynamo Studio 2017
  • Dynamo Core
  • Dynamo Revit

Each of these 3 programs will have their own version number. Sometimes they might even look like the same number. When both D4R and Studio are installed on your machine, they will share a common Dynamo Core.

For specific questions about your particular setup, it would require providing the team about those 3 version numbers, what version of Revit you have installed, what paths you are pointing to in the Manage Node and Package Paths dialog. We would need those in order to determine if a bug exists or if something is missing with the setup.

Hope this helps.


#15

I don’t have Dynamo Studio Installed.
l changed the path in Manage Node and Package paths (my path is the only one listed).
I have tried using path c:\Dynamo

But l’II give the default path a try.

What I don’t understand is why it can find my nodes but not the packages.


#16

@Racel_Williams, thanks for you elaboration.

I am however very surprised. The packages I have mentioned has zero-touch nodes, but many of them has also many “normal” nodes (.dyf). I am surprised that the entire package disappear if the package holds a .dll. file in the bin folder. Thats very vulnerable in my opinion.
The core nodes can see the difference between what is dependent on the Revit API and which is not. Why isnt that the case with packages as well? The dyf files should load in many cases…

Here is room for improvement in my opinion.


#17

Hi @erfajo - Definitely, I agree there is room for improvement. Just to clarify, its not the presence of the .dll that is causing some packages to fail. If the package contains calls to Revit API functionality and the system can’t call the Revit API, it is possible that the loading of the entire package will fail.


#18

I just installed the bakery package…for some reason the installation creates an empty “dyf” folder with just the installation script .
a nested folder inside this folder( extra/dyn) contained all scripts…I copied and pasted those and voila all scripts are available!
…just saying a a bloody dynamo beginner.