Package not showing in Library

Its Friday after 5 so I am probably just missing something and need to go home but for the life of me I cannot find the package in the library. I had it in there but it was out of date so I uninstalled closed out of Revit and reinstalled and its not there. Closed Revit again reopened and still not there. I am taking this as a sign to leave for the weekend. Thank you to anyone who can help.

Actually just had this happen to me as well with archi-lab. It might be the dll in the bin folder. Maybe try removing that and opening Dynamo? I haven’t had a chance to try my self.

I tried deleting the whole archi-lab folder including the dll file but no luck. It would not show up until I installed the Feb 1 edition.

I am using 9.0 with rvt 15.

Once you have put them into the packages folder (unzipped) You need to go into the ‘bin’ folder and Right Click > Properties on each of the .DLL files and UNBLOCK them (Button at bottom of General Tab in Properties)

Do this with Revit and Dynamo closed and when you re open they should be loaded.

I have to do this with all the packages i download for Dynamo.

Hope this helps


I have checked my DLL files and I’m unable to unlock the file. I don’t seem to have the option. (as displayed below)

Hi, I have the same problem: I can’t see any unblock Button anywhere in the file property. Did you find a solution to the problem?

based on the write date of 2/11/16 I am guessing that is the one you downloaded? There is something wrong with it as far as I can tell. Try downloaded the one before it (from January) or the latest one.

ArchiLAB is not compatible with Dynamo 1.0 at this time. Konrad is at RTCAUS and will update after getting back. Use Dynamo 0.9.2 to utilize ArchiLAB packages in the meantime.

1 Like

I have a similar problem with the clockwork package for 0.92. Reinstallation of Dynamo and the clockworkpackage does not help. Unblock dll button is not available. any suggestions?

archi-lab, bumblebee and mantis shrimp are now available for dynamo 1.0

1 Like

I got a bit of the same problem…I open my dyn and got some red nodes…I reinstall the package, I got the message that the package is already installed (but it isn’t in the library). After reinstall the node becomes grey again. But when I close Dynamo and reopen. The node is red again.

What is going on.

There are no blocks on the files,and did try to start Revit as Administrator…I’m lost…

Hi Arno,
Which Dynamo versions your using?

deleted the whole dynamo file in roaming…That did the trick…just need to import all the costum nodes again. Can’t copy it from and old directory (then the red nodes are back)