Having trouble unblocking .dll files

yes, it either gives me an error, or says downloaded, but doesn’t appear in my my library.

Which dynamo and revit version your using?

Revit 2016 & Dynamo 1.2.1

@cwilliams Looking back at your unzipped files location. Your unzipping files on your desktop. You need to unzipped it in C:\Users<Username>\AppData\Roaming\Dynamo Revit\1.2\packages\LunchBox\

Edit: Make sure you close revit before you extract zip.

again, it will install, but not show up in my library.

This is the path for the “Show Root Directory”

now it is showing contents, but still not loaded into library.

@cwilliams Looks like it has installed. Have you tried restarting Revit.

Could you show us screenshot of Library.

Thank you for all of your help KulKul.

I have restarted Revit. I have even logged off my computer & logged back in since installing the latest packages.

I don’t know if it makes a difference, but our company is cloud based.

Here is a picture of my library (I think this is what you want).

I am able to get the Lunchbox v. 2014.7.14 to install (pretty out of date), but no other packages.

@cwilliams Try changing packages paths to default location C:\Users\UserName\AppData\Roaming\Dynamo Revit\1.2\packages. See if that helps. May be you don’t have rights to install anything on server.

@cwilliams Try also changing the CustomPackageFolders section inside the DynamoSettings XML file.

sorry, this might require a little more hand holding. How would I go about that?

Have you tried changing path location under manage paths location.

yes.

I was able to download a very old version of Bumblebee & Lunchbox. Unfortunately they don’t have all the nodes that my coworkers use in their scripts, but some of them. I am contacting our IT about not having enough rights/certain rights to see if that’s the problem w/ newer versions.

This is my manage node & package paths.

@cwilliams Edit the paths to your c drive as shown below.

If I follow you’re path, once I get to Roaming, there is no Dynamo.

Create the folder structure then if it is not there, and put the package there and let us know if it works.

My feeling is that there could be a embedded path somewhere looking into your %AppData% folder for the relevant files but of course it cannot find it so therefore not loading.

I had a similar issue where any package that had a dll wouldn’t show up on some of our company computers. It turned out to be a permission issue, and it was resolved once our IT guy gave everyone read and write permission to the folder where all the packages are stored.

Thank you! I’m hoping this is the case. I contacted my IT dept. yesterday, so hopefully I get a response soon.