Having trouble unblocking .dll files

I’m having such a hard time getting my “installed” packages to show up on my toolbar.

I am trying to follow Alisder’s instructions in this thread:


However, I can’t unblock in the bin folder like he says, just the unzipped folder itself. This is what I get when I go into the zipped folder/bin/ & right click a .dll file:

Hi @cwilliams

You need to extract zip files and unlock the dll.

1 Like

I only get the option to unblock while it’s still zipped. I feel like this shouldn’t be so hard.

Here is a freshly unzipped file.

This what I get under manage packages.

All packages show installed, but it’s not reading any .dll files.

@cwilliams Have you tried installing through Dynamo online search package?

yes, it either gives me an error, or says downloaded, but doesn’t appear in my my library.

Which dynamo and revit version your using?

Revit 2016 & Dynamo 1.2.1

@cwilliams Looking back at your unzipped files location. Your unzipping files on your desktop. You need to unzipped it in C:\Users<Username>\AppData\Roaming\Dynamo Revit\1.2\packages\LunchBox\

Edit: Make sure you close revit before you extract zip.

again, it will install, but not show up in my library.

This is the path for the “Show Root Directory”

now it is showing contents, but still not loaded into library.

@cwilliams Looks like it has installed. Have you tried restarting Revit.

Could you show us screenshot of Library.

Thank you for all of your help KulKul.

I have restarted Revit. I have even logged off my computer & logged back in since installing the latest packages.

I don’t know if it makes a difference, but our company is cloud based.

Here is a picture of my library (I think this is what you want).

I am able to get the Lunchbox v. 2014.7.14 to install (pretty out of date), but no other packages.

@cwilliams Try changing packages paths to default location C:\Users\UserName\AppData\Roaming\Dynamo Revit\1.2\packages. See if that helps. May be you don’t have rights to install anything on server.

@cwilliams Try also changing the CustomPackageFolders section inside the DynamoSettings XML file.

sorry, this might require a little more hand holding. How would I go about that?

Have you tried changing path location under manage paths location.


I was able to download a very old version of Bumblebee & Lunchbox. Unfortunately they don’t have all the nodes that my coworkers use in their scripts, but some of them. I am contacting our IT about not having enough rights/certain rights to see if that’s the problem w/ newer versions.

This is my manage node & package paths.

@cwilliams Edit the paths to your c drive as shown below.