Can't get lines from linked CAD

Hi all,

There’s something strange going on with my Dynamo script. I want to select some lines, placed in a linked CAD-file, and use them in my Dynamo script. The script worked a couple months ago fine, and now it’s causing me a big headache.
I need to use the CAD.CurvesFromCADLayers from Bimorph to select the right line, based on the layername. But it returns empty lists on the Curve output, while the Layerkeys output gives all te layernames. I tried all different things, but it all ended up taking lots of time without any progress.

  • When I select a random CAD in another Revit project, the node works fine.
  • When I select a random CAD in the same Revit project, the node works sometimes (depending on the *.dwg)
  • When I create a new CAD, link it in the same Revit project, and select it, it doesn’t work.
  • When I load my CAD in a random Revit project, it also works.

There’s something strange about the combination of the Revit project and de *.dwg. I’m all out of ideas.

If this is specific to your combination dyn and rvt, we would need one or both of those to see where the issue may be.

You can use “BriMohareb_2023” it has node to access Autocad as an application not as link.

You will find an example in this link