Batch print PDF using Dynamo

I’m trying to create a script that batch prints PDFs for me. The script that I’ve made still wants me to manually type in the name for every PDF when I run it instead of doing to automatically. I’ve read a bunch of other similiar posts about the same topic but I still can’t manage to find a solution.

Any help?

Thanks in advance!

Hi @Denish97,

It is probably necessary to configure the virtual printer to put it in “silent” mode but not sure if this is possible with Microsoft print Pdf.
However There are other virtual printers like PDFCreator.

Do you know I can do that with the virtual printer Adobe PDF (or Bluebeam)? I can’t find it in the printer settings. I actually copied the first script that you made from this post Batch Print PDF

I have no experience with Bluebeam but it works fine with Adobe PDF.

1 Like

It’s working with Adobe PDF but the PDFs get a different name than what I asked for. I would like to name them as the name of the sheet. Instead, it gates the name “Name of the revit file + “sheet” + Sheet number + sheet name”. I just want the sheet name.

I can’t reproduce your issue so it is probably an Adobe PDF configuration problem.

I really would recommend PDFCreator, it is a free pdf printer that allowed for a specific dynamo printer to be made.
This way you can use a printer specifically for dynamo that doesn’t give you a save as prompt.

Of course as Alban suggested other pdf printers work aswell

1 Like

If you want to do this in Bluebeam then you’ll need to modify the Registry or turn off “Prompt for file name” in BB Administrator, but then it won’t ask for anything unless you have 2019+ and then Revit has its own settings now you can set up.

It’s not working for me. I encounter two problems with this script.

  1. It only prints one sheet as PDF.
  2. The name of the PDF is incorrect.

I don’t know where to find those settings in Bluebeam :frowning:

Can you place watch nodes before the filepath and views input or pin the contents below the nodes?

Of course

Okay, so I installed PDFCreator and the only problem I have now is that it doesn’t give the PDF-files the correct names.


Have you configured PDFCreator like this?

This is what it looks like for me

I think I’ve made it work now. Every PDF-file has been given the correct name :slight_smile:

The only problem remaining is that it prints in greyscale and every time I run the script in Dynamo, the PDFCreator program opens up with the saved files. I don’t want that.

You have a different version of PDFCreater compared to me, or Alban.
The checkbox to disable opening after printing is not available in your screenshot. It might be at the printer settings?

What version of PDFCreator is that?

They are in Revit on the Bluebeam tab.

I’m using PDFCreator 4.2.0. Which version are you guys using?
I also disovered that the checkbox for opening after printing is missing for me. I can’t find it anywhere in the settings including the printer settings.

Ah yeah i am using version 4.0.4

Will try to find this option, i will report back later:)

Did you assign this profile to the PDFCreator printer?
Just creating the profile is not enough, just checking to make sure…

To clarify…

Your screenshot shows settings.
Can you go to the tab Profiles and show your settings in that tab?

1 Like