Zach's example using AC


#1

Morning all,


after watching Zach's latest videos i was going to slightly expand by creating the curves using Dynamo(instead of selecting them).



Works fine except for a small detail. When i update the curves points value, the XYZ of the AC don't seem to update. Any idea why?



#2

Thanks Zach, and D :slight_smile:


#3

Hi Daniel,


Interesting . . . it looks like the points are updating on the AC, BUT they are one change out of sync with the curve. That is, I move curve from A to B, component does not move. Change curve from B to C, component now moves to B, etc. We'll take a look at what is happening and get a fix in. Thanks!


#4

Daniel, to get the adaptive component to update I had to move the mouse focus back to the Revit drawing area, then went back to Dynamo and set the input for IsReference (for the curve that I updated one of it's point coordinates) and then all updated properly.


#5

Still not updating properly here


#6

Here's the version I'm playing with. The adaptive components are not updating properly. If you toggle the IsRef input (0 to 1 or 1 to 0), then the adaptive components are updated with proper XYZ coordinates for the placement points. Note you need to have a massing file open and a loaded 4-point adaptive component. Make sure to pick the family first before running or it'll crash (shouldn't be happening). I'm also noticing that some inputs get duplicate connections when you open the file and to get rid of them you have to do a lot of double-clicking on the output nodes and re-connect etc. to clean things up


#7

In the example you sent me (ends in "2") I'm finding that the adaptive components do move but are not properly aligned to the curves. When I set the value IsReference to 1, then they update properly for some reason. Not sure exactly what is going on.


#8

You know, the sample doesn't crash when you have not picked an adaptive component family to place but this example does. You have to uncheck the Run Automatically option before opening it, locad a family and pick it and then check the option again. I think there's a bug in there somwehere. Still playing with it, will post an updated .dyn if I figure it out.