Workset not changing

Hi all,


I have been trying to segregate my model into worksets but after I have finished some of my link files are still in the wrong workset instead of the correct one (I can see this when opening and closing worksets as it becomes visible/invisible with Level 07’s workset) even thought when selecting the link model in Revit it shows the correct workset in the parameter/properties.
image
Anyone has ever encounter something like this? And would you be able to shine a light on the issue?

Thanks you in advance

PS: I have been successful segregating all other elements with the same Dynamo editing the Category/Element/Links.

Hi @JocoYo
Verify also the correct workset under “Edit Type” button (in the top right of your image).
Cheers

If so, modify your script to set workset for instance and type of your revit links.
Cheers

@paris I have checked and both are showing the correct workset and still the revit link becomes invisible when closing the Level 07 workset.
Any other thoughts on what could be causing the issue?

Hi @JocoYo
maybe can you send a piece of your project?
Cheers

@paris No can do :sweat_smile:. The project is live and has sensible information the the companies involve do not want divulging just yet. :roll_eyes: I would love to to find out if anyone could see the issue. :wink:

@JocoYo With the current workflow, it looks like you are inputting the link type into the element. You need supply the Link instance to change the workset, this image will show how to obtain the link instance using a drop down provided by the Rhythm package. The workset nodes shouldn’t matter as long as your fulfilling it with an element id.

Hope this helps!

1 Like

@patrick_podeyn Hi thanks for the input. However, I have tried changing both the instance and the type parameters both with in the native Revit and with your example and they still disappear with the other workset :thinking: don’t know what else I can do :grimacing: :exploding_head:

He’s not talking about type vs instances parameters. He’s talking about the type vs instance of the link. The Link Type is like the definition. The Link Instance is the actual instance of the link in the model. You’re changing the Type (which doesn’t do anything) when you should be changing the workset of the Instance.