Welcome to the Dynamo Forum


Welcome to the new and improved Dynamo Forum!

Please make yourself at home and feel free to ask/answer questions about Dynamo, the general purpose graphical algorithm editor for designers, architects, artists, and engineers. For those who don’t already know, Dynamo is both a standalone design environment and an extension to other applications such as Autodesk Revit and FormIt. Dynamo users can create geometric systems, analyse existing projects, turn data into built forms and built forms into data.

The Dynamo discussion has been lively and exciting, but has been burdened by a clunky interface, search, and notification system. We hope that those days are behind us with this new site. What you can expect on this forum:

  • Discussion by and for designers, architects, engineers, artists, programmers, and other folks interested in making computational stuff.
  • A friendly environment to ask questions and find answers about all things Dynamo. There are no stupid questions, we all have something to learn and something to contribute.
  • Tools for identifying the best answers to open questions.
  • Methods to reliably receive updates to posts you are interested in.
  • Pointers to resources on computational design, parametric workflows, and new ways of thinking about design.

This site is powered by Discourse, an open source system that’s a happy medium between a more developer oriented Stack Overflow Q&A system and a more conversational discussion board. To understand more about the features, check out this page: https://www.discourse.org/about/

Thanks for visiting, and we hope you make this site a regular part of your day.
The Dynamo Team

A couple things to note for folks who were invested in the old forum:

  • You may need to add some information back to your profile. Not all of the data fields in the old Forum had counterparts in the new one. If you want to provide more than 1 link on your profile, add it to the “About Me” section.
  • For the moment, you may need to log in seperately to the main DynamoBIM site and the Forum, as the authentication tools are slightly different.
  • Tag information on older posts were now able to be migrated, so tags like “Python” or “Revit” have been stripped out. This data can be added to new posts


nice work- looks better and certainly seems snappier

The big question: is it now code friendly and it the format-mangler fixed ?



Looks very good. Thanks to all who has made this :+1:.


@Andrew_Hannell - you can use the code block item in the toolbar to add code. This should even auto-highlight for the most common languages. Here is a javascript test:

//Update Level Spinner
	function isCurrent(whichNode){
		for (var key in whichNode){
			if(whichNode[key].current == 1){
				return key;


Being a bit picky here, but it’s a bit odd that the search tool now gets added to the menu bar. Took me a minute to realize that it was specific to the forum. Otherwise :+1:



New update forum is great.
Thanks for new format.
But, I found the files of DYN on forum are lost.
I can’t save or download them.
I am using ‘chrome’ and ‘internet explorer’ browsers.


@Hyun_Tak - Can you point me to the specific file(s) you are unable to download? Or try this one: 01_ByCoordinates.dyn (3.3 KB)

Let us know if you can download the new resource. We are still working on migrating our assets over, so maybe that is what is happening.


I can download your file.
But the old posted files lost the link and I can’t retrieve them any more.
Here are sample posts with broken dyn & related revit files.



I want to ask one more question on the forum.
Is there a limit on search result?
I only got 50 results per each search.
I want to get more to fine the solution I am looking for.


Some tricks and features using the new forum can be found here:



Thanks for catching this @Hyun_Tak. During migration from the old forum, some links were disabled. All the links to dyn, rvt, and other attachments should be fixed now. Please let us know if you are having any other issues with this.


@Hyun_Tak - 50 is the limit right now. You can try filtering results to get more control over what you want. Just click on “options” underneath the search bar.


Thank you for the new forum!!
It’s much more useful than the previous one.


Any way to restore (or find) the attached images from the old forum? I’m seeing many posts like this where the images are just too low-resolution to read:


I love the new forum, but as truevis said, some old screenshots are useless now, because they are too small


@truevis @Thomas_Vogt1 - As I mentioned in a previous post, you can still access old posts in their original form by typing in the correct url. Just use this format:


For example:

I am not sure how long we are going to keep these old posts active. Please keep in mind that we might archive them at some point.

Website Images Won't Expand
Ungrouping & Purging All Families in a Model
Number elements along a line

@Racel_Williams that is very useful until the original posted images can be preserved.


@truevis - Unfortunately, we have completed the migration process over to this new forum. We don’t have plans to bring the original images over to the new site. If you need them, you may want to save them or add them back to the thread.


@Racel_Williams leaving the old posts as they are might be a good compromise, unless there was a top level URL to rip and save the old forum data (especially the images).

Perhap add grey-out-the-text CSS to the old forum pages to show they they are for reference only.

Deleting content from forums where people have put in much effort to contribute should really be avoided. (Lessons learned from the old AUGI, eh?)


very helpful, I like a lot