Unable to Write to Excel

I Will start with the basis that this may not be a Dynamo Issue.

After having swapped out a computer and installing Fresh Revit 2018 & Dynamo. The ability to write/read to Excel no longer works. This has been attempted in Dynamo Revit / Sandbox / Studio - None work.

Excel Functions, and Revit Function as normal other wise.

Curios if anyone else may have seen this condition?

Write to Excel Null

Hi @Mike_Engel1

What does the error says?

It Reads the following.

“Warning: Excel.WriteToFile Operation Failed.”

@Mike_Engel1 Do you have Microsoft Office 365 Business by chance? I recently had this problem after Office 365 updated, and @Kulkul recommended uninstalling and reinstalling Microsoft Office 365 Business - after this my Excel nodes in Dynamo worked again. This thread here also offers some other solutions:


Thank you all - Fixing the Registry and an Reinstall of Microsoft Office Fixes it.

This only brings up the want to have better / more effective search ability on this forum.

@Mike_Engel1 Could you mark the post as solved. You’re Welcome!