Set parameter value for "Family Type" Parameter

Hi, I’m trying to update the family type parameter with Dynamo. Looks like it isn’t as straightforward as I thought. The approach below is giving blank value.

Hi @Sujan

you are just trying to pass the family type to the node. Check first what type the parameter accepts.

1 Like

Hi @Meychik,

It shows the value is a FamilyType Object.

I see, it takes a family type. Try to create a new element and to pass the value from “Parameter.Value” to it. If it works, it means that the nodes sets the parameter correctly. If not, you need to find a way around.

1 Like

No Luck :neutral_face:

Two things that can prevent this are:

  1. If the family being set is not of the same category as the parameter. Family type parameters only accept their initial category chosen on creation.

  2. If the family is drawing upon non-shared components for the family type parameter. Not 100% on this one but I seem to recall if you have a non-shared value set then at project level that component/parameter does not naturally point to shared level components.

1 Like

Hey @GavinCrump , you were meant to be on break! :smile:

Let me check these when I’m back.

1 Like

Making it a Shared Component Worked thanks.

1 Like

Glad it worked!

On break from youtube but doing everything else but that.