Set Invert is this a bug

Have been trying to set pipe invert and noticed this culprit. Am I doing anything wrong?

@craigp can you run this a few times? unfortunately I could not find a very clean solution to set the inverts at start and end at the same time, but it should converge after a number of times.

Sorry didn’t get you. Can you show me one example how to do number of times?

I tried example you shown on below post but still the same issue. @keith.sowinski any thoughts?

I’ve recreated your values.
In the Toolkit you get the actual invert for a real pipe with the cross-section that is orthogonal to the centerline (in red).
In Civil 3D you get an abstract pipe (in blue) with the cross-section always vertical, reagardless the slope. With an 85.7% slope this is the difference that you see.

In the Toolkit, the Invert takes into account the slope, hence the difference in the value in the properties.

Thanks Paolo. I am not seeing the same what you’re getting. Could you please try on this dwg file.

Set Invert.dwg (946.1 KB)

Here is the dyn file:
Set_Invert (1).dyn (38.9 KB)

1 Like

Thanks a lot paolo. But I can’t find the same node which you have Set Invert. You will publish the latest package?

This is the difference that I’m talking about with your network

What should I do so that it comes down to center? How can I fix this issue?

to do what you want you need to set the StartPoint / EndPoint of the pipe not the invert…

1 Like

That’s it. Thanks a lot @Paolo_Emilio_Serra1. I owe you beer :beers: