Set Family Parameter Value "Instance"

Am I going crazy? didnt there used to be a Set Family Parameter Value for “Instance Parameters”

It seems the latest build 6.3 only has Set Family Type and Set Element, which only handles type Parameter.

Also the “Get Family Parameter” only pulls type parameters through.


Not sure about the latest daily builds, but Set Element Parameter is able to handle instance parameters in the regular 0.6.3 release (and so is Get Family Parameter).

I’ve been having this issue also, and for future reference, in the 0.7.1 release this component is called “SetParameterByName”

i am experiencing the same problems.

with elements i have no access to type / instance parameters.

example: window

parameters: width, height

-> whatever i try no result

only way is to select ONE element type and then query the parameters i need.

in older builds the access was available with “elements of type” - “windows”…

I also had this experience until I saved my revit model, are you working with a family embedded into another family or a family placed in a project? Do you notice any differences between these setups?


For clarification I mean that altering parameters by name did not actually alter them.

I am still having this same problem. Both in 6.3 and 7.1.

I have created a curtain wall panel which I have added to a divided surface in the Conceptual Massing Environment. I want to allow the thickness of the panels to respond to their distance to a certain point (An attractor point). I can select the panel family through “Family Types,” and I can control the value of the thickness when I have it set as a Type parameter, but it won’t show up once it is changed to an Instance parameter (It won’t show up in the “Get Family Parameter” dropdown, and when I use “Element.SetParameterByName” and enter “Thickness” in a “String,” it says there is “no parameter found by that name”).

I want to have this set as an Instance parameter since I want each panel’s thickness to be unique. Interestingly, when I tried to set the Type parameter to different values in 6.3, Dynamo would crash (I assume because it wanted all values to be the same, and I was giving it a list of values, but in 7.1 it will simply give all panels one value).

Any help would be much appreciated!

I have two samples online that should do more or less exactly what you’re trying to achieve. (They are in 0.6.3 and will most likely not run under 0.7.1 without some modifications.)

The first is a one-point reactor, albeit with freely placed CW panels / adaptive components. The other uses a divided surface, but has a two-point reactor pattern. If you marry the relevant parts of these two graphs you should have what you’re looking for.

1 Like

Hi Andreas,

Could you please update your github links? I would really appreciate seeing these samples but the links aren’t working. Thanks!

Hi, these are the most recent versions of those examples:

I doubt that they will still work, though.

1 Like

Possible solution:

I believe I was searching for the same node as the OP, and I believe it was called “FamilyInstance.Type” - I too could not find it in my Dynamo library (Dynamo

I wanted to find the family type by instance for the “element” input of an “Element.SetParameterByName” node with this “FamilyInstance.Type” node.

Instead, I used a “FamilyInstance.GetFamily” node and a “FamilyType.ByFamilyAndName” node, with a string node to specify the name of the family type. This worked for me.