Parameter setvalue input types are not matching

Hi, I’m new to dynamo. I want to change the parameter of the family I created. They’re just simple dimensions which were measured and turned into type parameters.
First I tried “set parameter by name”, but it always said “no parameter found by that name”
then try to find parameter from the family and use parameter setvalue code
they are exactly string and double inputs. Don’t know why it shows warnings “one or more of the input types are not matching”

Try an ‘Element.SetParameterValueByName’ node instead.

That node was the original one I tried. But it always showed no parameter was found by that name.
when we create family, assign parameters to dimensions, can these family parameters be directly cited in dynamo? Do they need to be turned into shared parameters or some other forms? I’ve also tried shared parameter, it still wouldn’t work.
Your help is very appreciated.

Are you in the project environment or family environment? Can you post the DYN and RVT you are using?

in project environment.Project1.dyn (45.4 KB) soilenvironment.rfa (352 KB)

You can create a new project, load in the family and run the dyn after selecting parameters.

Thank you for yr help! I know why now. The type parameter can not be adjusted in the instance. I need to set these parameters as instance parameters.