Script runs first time I run, the second time I try running it though it crashes unless I restart Dynamo?

Hi my problem is this the first time I run my script it works just fine if I try running it a second time though it either crashes or will cause revit and dynamo to become unresponsive indefinitely, if I close dynamo and rerun my script though I don’t have any problems I think the issue is from needing to place transaction start and end nodes somewhere from looking at the forum topics, could someone please take a look at my script and help me identify where I should place these transaction start and end nodes or what it is if not that I need to do to fix my script please, not quite sure how to do it myself?

My Script is uploaded here if anyone can please take a look and help me fix it

I don’t think it has anything to do with transactions.
Dynamo nodes don’t recalculate if nothing has changed, therefore they pass on the output they had from your previous run. Easiest way is to just close the script without saving, open it again and run it. There’s also a node in Springs UI package that forces all nodes to refresh. You could use that too. It doesn’t work with Dynamo 2.0 though.

Hope this helps.

Could you please let me know the name of the node in Springs so I could give it a try to see if it fixes my script please?

It’s in SpringsUI package. Search for refresh you should be able to easily find it.


Thank you found it.