Rhythm.TextBoxInput not working

rhythm
dynamoplayer

#1

I am trying to use Rhythm.TextBoxInput node coupled with Bimorph Nodes to duplicate sheets with Dynamo Player and allow user input for Suffix and Prefix.

When i run the script with just string values for Suffix and Prefix it works.

When i try and run it using Rhythm.TextBoxInput it gives a warning and wont run. I watched the video on the Rhythm website. Am i doing something wrong?


#2

Hmmm… I have not looked at that node in a while, I am actually retiring it. I would suggest using @Mostafa_El_Ayoubi’s package data-shapes, or since you are in Revit 2018.2 to just use a string input.

Here is the data-shapes setup

Also, @William_Ruffenach. Where do you have the packages installed? I am thinking the node is failing as it cannot find the logo I embedded when I made it. Part of the reason it is getting retired is this and Data-Shapes is way better for popup UI


#3

John,

Thanks for the quick reply, Input string worked perfectly! I didn’t see this node when searching, by your comments i believe its potentially only part of 2018.2.


#4

That is in fact only part of that Revit version. John was indicating to try the Datashapes package, which I highly reccomend as it allows for a more refined UI (including link’s to help, cancel part what through, etc)