Revit 2020 Dynamo 2.1.07733 Default Background Preview greyed out

Hi,

I have Revit 2020 and dynamo 2.1.07733.

The problem: the code does not display any geometry except in revit.
I can only see code preview but no geometry preview.

Default Background Preview option is greyed out.

I tried to update NVidia drivers, and force Revit to run on NVidia, but the button is still greyed out.

Can someone help with this issue?

Try forcing Dynamo to run on the nvidea card as well.

can you check what version of directX you have installed first - and then try running this:
https://github.com/DynamoDS/Dynamo/blob/master/tools/install/Extra/DirectX/DXSETUP.exe

3 Likes

I figured it out - my directX wasn’t up to date.
I installed the latest version from the Microsoft site and the Dynamo background preview menu became available.
https://support.microsoft.com/en-us/help/179113/how-to-install-the-latest-version-of-directx

1 Like

This didn’t work for me.

I have directX 12 - can’t seem to find however if this is up-to-date.

I’ve checked for updates using Windows Update and there didn’t seem to be any…

Any ideas?

1 Like

@Michael_Kirschner2 thx for this. solve my problem

I have the same problem that you have, I run the Dynamo through Revit 2020 and the 3D Background does not appear, I run it in an Intel Core I7 3rd generation with an Nvidia 960M and with 32GB of memory, I have reinstalled Revit 2020 and even reinstall the SO with all the controllers, and this doesn’t help, I have Directx 12 Installed and up to date.

Have you any idea to solve this issue?

please install directX from the link above. It’s an older DirectX required by the version of Dynamo shipped with Revit 2020.

@anderson.martinezdq similar issue discussed recently here:

Thanks a lot!!! :smile:

Translated by moderator. Original post below the line.


Regards,
I get that the file cannot be found.


Original post below:


Saludos,
Me sale qe no encuantra el archivo.

Hi Michael

I am having the same issue with the viewport of Dynamo on a recent install of Revit 2021. I have windows 10, DirectX 12, Nvidia K1100M, and the latest graphics card driver. I tried running the dxsetup application but I get an error message saying that it can’t find dsetup.dll.
Any ideas?
Thanks.

Angelica