3D preivew is missing from Revit 2020.2 Dynamo 2.3

I do not why but I got Revit 2020.2 with Dynamo 2.3.0 and I am missing 3D preview. I can see Grid so it is not graphic card issue.
Any help will be appreciated.

I just realized I can see a preview in Revit, just missing preview in Dynamo

Is there any way to re-install dynamo for Revit 2020.2?
Not sure how to solve my problem? and why I can not see preview…

Hi @Michal_Dengusiak can you try installing https://www.microsoft.com/en-us/download/details.aspx?id=8109

@Michael_Kirschner2 thanks a lot fore reply,
DirectX installed

but still missing preview,

I just downloaded DynamoCoreRuntime2.4.0

when I open I can see the preview but not grid

I can see a default is integrated card

when I change to NVIDIA is correct

is there any control of Dynamo Revit? hmmm

Hi Michal_Dengusiak, Where did you find the option on this image:


I’m having the same issue I have Dynamo on Revit, I tried on the Nvidia control panel but did not fix the issue.

Where exactly you find that option “run with graphics (default)”?

I have this option when I do right click on my Program Revit or Dynamo

make sure your NVidia is up to date

and here you can chose how to run

however in my previous laptop Lenovo this was blocked by IT so I did not have access to this settings under NVidia,

I’m missing that option. I searched for some troubleshooting I found that option was removed according to a recent update.

"Run with graphics processor" missing from context menu: Change in process of assigning GPUs to use for applications | NVIDIA.

And the Nvidia control Panel is not helping with all the Revit options I don’t know which one to pick.
They let me edit but it does not fix the issue.

It shows more than one option on the drop list, I only have Revit 2021 installed. Also when I want to add a program I get at least 5 Revit options and a Dynamo Player Icon is there as well.


I also have the Autodesk Revit with the Grayed out options like the one you have, Sometimes is there, but then I remove it, and then I cannot add it again.

Another troubleshoot said that I need DirectX10, I tried installing it but the Windows site is down.


I’m not sure if I will be capable of fixing this issue. Is it ok if I try running dynamo on a blank Revit project?
How necessary is that 3d preview for Geometry?

Thanks for replying.