3D preview grayed out

I’m using Revit 2020 and have a problem with Dynamo as the option of 3D preview is grayed out as shown in the screenshot. I have NVIDIA Geforce graphic card and tried updating the driver as well as changing the settings in NVIDIA control panel as it was recommended in previous topics but it didn’t help. Also tried to reinstall Revit after that… What else could I try?

can you try updating your directx?

Thank you, it helped :slight_smile:

Same with RX5700XT and DirectX 12.

Hi all, I have the same problem. I have DirectX 12. I tried to updating and it is still not working. Any advice?
I have Windows 10
Nvidia Geforce GTX
and I have tried running Revit with either High-Performance Nvidia Processor or Integrated graphics.
Help please

Hi @nicoarellano

Check these settings in Dynamo:

If it didn’t work try installing:

1 Like

Hi Kulkul,

I tried updating the DirectX again and it finally worked.
Thank you so much!