"There was an error creating a background preview in Dynamo"

Hey guys,

One of our interns is having a problem with both the menu tree and the 3D preview. The error message reads: “There was an error creating a background preview in Dynamo. This could be due to a lack of graphics resources on your machine. See the log for more information”

She downloaded Dynamo version 2.4 as well as 2.1 and both have the same issues.

We followed all the steps on this page: https://github.com/DynamoDS/Dynamo/wiki/How-to-Utilize-Dynamo-Builds, as well as doing several variations on these instructions (integrated or high-performance), set Dynamo as administrator, checked the video card in the Bios, etc. But all to no avail.

She has DX12 installed as well as several C++ redistributables.

She used to have the other error message as well: “LibraryUI: Could not load file or assembly ‘CefSharp.Core.dll’ or one of its dependencies. The specified module could not be found”, but for some reason this disappeared (but without actually solving the menu tree problem).

She doesn’t have any version of Revit installed. Might that be a problem?

We checked this topic as well, but did not help unfortunately: Revit 2020 Dynamo 2.1.07733 Default Background Preview greyed out

So it seems we hit a dead end. Does anyone have the golden solution to this? :wink:

Update 1: She has a brand spanking new Dell precision 5540, so I don’t think hardware is actually the issue.

Update 2: After a restart, the menu tree now does seem to work, so that’s one problem down, but the 3D preview still to go…

Thanks again for the help,


Hi @Michael684

What’s graphics card config?

She will likely need Revit, Formit, Civil3D, AutoCAD, or some other application which has the geometry engine installed as well.

this is a perfect opportunity to test out the latest dailybuilds which should fix this issue - previously an older directX version was required but - now dx12 with win 10 OOTB should work. Please let me know how it goes.

As Jacob says, you’ll still not actually be able to use the Dynamo geometry nodes without some ADSK software present.

Hi Michael,

Installing the latest daily build did not resolve the 3D preview issue unfortunately. But if Dynamo geometry was not going to work anyway in this setup, this was also not the solution we were looking for (we need to generate some geometry).

Hi Jacob,

She installed Revit 2019 and was then able to start Dynamo 1.3 from Revit with a working 3D preview.

So she then installed Revit 2020 to see if the preinstalled Dynamo 2.1 version will also work, which it does fortunately.

There is still no luck though with the sandbox versions. Seen as there is no installer for that, would it even help to ‘reinstall’? Any advice on this? Because it would be convenient not having to start Revit each time she does some work with Dynamo…

Thanks again!

Right, we found the solution and it was to turn on the background preview.

We had checked that before and is used to be greyed out (before installing Revit).

Hope this may help others,



I should have mentioned that the preferences might have set this off :frowning: