Revit 2017.1 and Dynamo 1.2 - Gone from Revit 2016

Not sure if this is a Dynamo issue or a Revit issue, but I just realized that when I ran the Revit 2017.1 update, I lost Dynamo from Revit 2016.
I had install on both Revit 2016 and 2017.
After the .1 update, my DynamoCore.dll shows
But Dynamo no longer shows up anywhere in Revit 2016

Hi @DaveP

Did you try restarting your Computer?

Apparently I had 1.1 installed previously.
It looks like the 2017.1 uninstalls 1.1, and then installs 1.2 ONLY for 2017.
Tried it on a different machine and here’s my C:\Program Files\Dynamo folder before the install

and after

As you can see, it simply doesn’t install the Revit_2016 files.

1 Like

I’ve got the same problem.

I had revit 2016 and dynamo 1.1, 0.8 and 0.9.
After install dynamo 1.2, I’ve lost dynamo 1.1 but still got 0.8 and 0.9 versions.

Same problem here. Any update or fix for this??? Frustrating when they pull this stuff and don’t issue a resolution.

Here’s a potential workaround:

  1. BEFORE Revit 2017.1 is installed, make sure Dynamo 1.2.0 has been installed on the target computer.
  2. COPY the following files/folders to a safe place:
    • Dynamo.addin file from the C:\ProgramData\Autodesk\Revit\Addins\2016 folder
    • The entire Revit_2016 folder from the C:\Program Files\Dynamo\Dynamo Revit\1.2 folder
  3. Install Revit 2017.1, which will also update/override previous Dynamo installs
  4. COPY the following files/folders BACK to their original locations:
    • Dynamo.addin file to the C:\ProgramData\Autodesk\Revit\Addins\2016 folder
    • The entire Revit_2016 folder to the C:\Program Files\Dynamo\Dynamo Revit\1.2 folder

This appears to be working, with the notable case being that Dynamo launched from Revit 2016 will show a Dynamo Revit version of and a Dynamo Core version of (Revit 2017’s Dynamo will show both as version

@Zach_Kron FYI

I think if you re-install DynamoRevit from the site you can reinstall for 2016 and 2017.

Hi All,
Yes, this is a “known issue” for the Revit 2017.1 installer, and they are working on it. In the meantime, after installing 2017.1, you can run the 1.2 installer available from to restore Dynamo functionality in Revit 2016. Apologies for the inconvenience, we are on it.

I have the reverse problem, I had dynamo1.2 installed on revit 2016 and then when I was upgraded to revit 2017 and ran the installer for dynamo1.2 it deleted my revit 2017.

hi guys am try to find a link to downlod
dynamo for revit 2016, please any one with a link. best regards