Refinery Server not running issue

#1

Hi all,

I’m playing around with Refinery in Dynamo 2.0.2 and am having an issue when creating a new study in Refinery - i get the issue ‘Server is not running’.

Is this an issue with the Refinery server actually being down or is it an IT issue whereby the network i’m on is not setup to connect to the Refinery server?

Anyone else have this issue pop up? If so, what did you do to resolve it?

Thanks!
ND

#2

Can you post an image of the error?

#3

#4

So the ‘server’ is executed locally on your C drive. Can you open up task manager and see if RestDynamoCore.Exe and RefineryServer.exe are running?

If not, my guess is that it’s an AV/ASW or Permissions issue (so local security).

Also what version of Refinery are you using? Be sure to keep up to date as a lot of this stuff changes fast.

#5

FYI @Lilli_Smith

#6

Got the same issue, but RestDynamoCore.Exe and RefineryServer.exe are running on the task manager. BTW, I am using Refinery 0.4.26

#7

What is the CPU usage of the RestDynamoCore tasks? If they and the arefinery server are all idling at 0% then you need to force quit the process tree for RefineryServer (right click it in the details, select end process tree - that will stop all the Refinery Server instances and the RestDynamoCore instances). Then close and restart Dynamo. Then restart refinery. Once you’re back in the process may or may not kick back off where it stopped

#8

got the same issue here and the RestDynamoCore.Exe and RefineryServer.exe are NOT running… i downloaded the last version of dynamo n refinery… what should I do to solve it?? Did u solve those issues???

#9

Restart your system as a first step. That usually solves it.

If not:

  • Close Refinery
  • Open task manager (ctrl + shift + esc)
  • Go to the details tab
  • Find both instances of RefineryServer.exe and all instances of RestDynamoCore.exe

If RestDynamoCore or RefineryServer are not idling at 0% then you just need to exercise some patience as they’re actively working.

  • If RefineryServer and all instances of RestDynamoCore are idling at 0% cpu:
  • Right click on RefineryServer
  • Select ‘end process tree’ from the list
  • Confirm all instances of RestDynamoCore and RefineryServer are closed
  • Restart Refinery
  • Stop any auto-starting run on restart, and delete the results as they may be incorrect due to the force quit
  • Start a new run in Refinery and confirm that RestDynamoCore and RefineryServer do not get stuck in another idle loop by watching task manager.
#10

Hmm, most of the time the cpu were idling at 0%. Have tried it your way @JacobSmall and it did show “the server is running”. But no cases were created right after I click “Generate”.

Looks like a common issue to me. I thought very few people would have this problem. Hope this problem would be solved in the next release. And please remind me if you have any way to solve this instead of using task manager. Thx~

#11

Heads up if you haven’t upgraded refinery yet. I’m pretty sure the latest update of refinery from 6 days ago 0.4.44 addresses a major cause of these hang ups; at least that was what was mentioned on the internal refinery boards. I haven’t upgraded yet and am still experiencing the described issues above. @JacobSmall fix totally works in the short term and is what I’ve been doing.

1 Like
#12

I have already upgraded refinery but it is still not working for me. When I opened the refinery server log, most of the time it returned the error “‘utf-8’ codec can’t decode byte 0xc0 in position 6”. I tried to google it and found that it might have to do with the language that is embedded in our windows system, but I still don’t have a clue how to fix it.

** Yes, @JacobSmall this happened to my sample files as well.
When I am at C:\Users\myusername\AppData\Roaming\Refinery. I found a log file and it shows:
UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xc0 in position 6: invalid start byte

*** @Neal_Burnham Sure, it is installed at C:\Users\myusername(my username is just some numbers without any characters like 1234)\AppData\Roaming\Dynamo\Dynamo Core\2.0\packages

#13

Does this happen with the sample files as well? If not upload the dyn that you’re attempting to use so we can have a look at possible causes.

#14

Hi Yuxin,

Can you provide us with your folder path to Refinery? For example:

“C:\Users\{username}\AppData\Roaming\Dynamo\Dynamo Revit\2.0\packages”

Thanks,

The Refinery Team, Neal

#15

@Neal_Burnham Sure Neal, it is installed at C:\Users\myusername(my username is just some numbers without any characters like 1234)\AppData\Roaming\Dynamo\Dynamo Core\2.0\packages

#16

What language are you running Revit and Windows in?

#17

It’s Simplified Chinese