Issues with runnig simple scripts with Dynamo 2.02

Hey Guys, im having a issue with Dynamo 2.02 - Just installed the new version (stable build)

Im doing this bechause i want to start getting deep with the new refinery. Im having a weird issue tough. First i did run the example file for Refinery, just to find out that it wasent working, i then tried doing a super simple script, like Circle by radius, and input a radius. This it wasent able to compute either. I get this warning shown on image below. Anybody know what the issue might be?

Btw, im able to read in to the model, like wich views i have and such. But its like the Geometry part, is totally broke. Hope anybody know what this may be? I did try a reinstall of Dynamo, dosent work either. But the dynamo core, i cant delete tough, due to the path, not being valid. I think this might have something to with all these problems. But any ideas??

what version of revit are you running on?
Can you also verify both dynamoRevit and Dynamo are version 2.0.2

Can you also add a screenshot of your control panel? I would like to see what versions of Dynamo are installed on the system.

Hey Michael, thx for the repli, im running it on Revit 2019.1

You say dynamoRevit and Dynamo, how do i check if they are the same?

Here is a screenshot of the control panel

Can you please try uninstalling both DynamoCore and DynamoRevit (as seen on your screenshot) and re-install using the same 2.0.2 installer?

Yes i will try that, but i need the IT guy to help me out, (Update tomorow) with that as told earlier, i cant reinstall the Core, it says that the path is invalid, wich i in the first place was suspecting for being the issue.

I get this, when i am trying to uninstall. I had some troubles with installing Dynamo, earlier, something about administrator rights, he helped me with this before, so i will try and get him to fix this. I will write back, if this helps me out. Thx so much for your time so far :smile:


can you please verify what folders that start with libG_ exist in the Dynamo core folder?

I cant acess the dynamo core, something about the way our network is structured, i will have my IT check it tomorow :slight_smile: I will be back :slight_smile:

Hey Guys, i now had my IT guy fix the installations, as show on the img. below

But still it dosent work at all. screen dumped, this really simple procedure.

Hey Michael, it looks like this. 2018-12-13_1050

I am completely unsure if it works, but have you tried running Dynamo as admin?

This does look similar to something I experienced before. Could it be that the LibG.Protointerface is blocked? Try to find that dll and see if you can unblock it like this:

Hope this helps…

I will try that. Im not using studio, tough im using the revit version, so dont really know wich .DLL to go to :slight_smile:

Hi @Phh the dynamo core folder has a bunch of extra libG sub folders - can you try completely cleaning out the dynamCore folder and reinstalling it? It seems it is not being uninstalled correctly.

Hey Michael, i did try to uninstall, and reinstall, that did not help me out. After this, i tried to delete the leftover folders, after reinstall and then install again. That did the trick and its all working again now… Thx som much for the time and suggestions. Apreciated a lot :slight_smile: