Problems with Dynamo(crashes)

Hey guys,

I’ve tried to install dynamo 2.5.2, after that my the software doesn’t work porperly, every time when I try to access new packages it crashes.

I’ve tried to uninstall Dynamo and re-install but this error keep happening. I’m not sure what to do to fix that. I’ve google it and I couldn’t find anything helpful. I hope some one here can give a hand.

Thank.

Method not found: ‘Void Dynamo.PackageManager.PackageLoader.add_ConflictingCustomNodePackageLoaded(System.Action`2<Dynamo.PackageManager.Package,Dynamo.PackageManager.Package>)’.

at Dynamo.PackageManager.PackageManagerSearchViewModel…ctor(PackageManagerClientViewModel client)
at Dynamo.Controls.DynamoView.DynamoViewModelRequestShowPackageManagerSearch(Object s, EventArgs e)
at Dynamo.ViewModels.DynamoViewModel.OnRequestPackageManagerSearchDialog(Object sender, EventArgs e)
at MS.Internal.Commands.CommandHelpers.CriticalExecuteCommandSource(ICommandSource commandSource, Boolean userInitiated)
at System.Windows.Controls.MenuItem.InvokeClickAfterRender(Object arg)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Dynamo for Revit doesn’t have a supported installer for 2.5.2. Revit 2019, 2018, and 2017 are capped at 2.0.3 and Revit 2020 ties the Dynamo build to the Revit installation.

How did you “install” 2.5.2?

1 Like

You are getting hung up on verbiage here man, and frankly, not being very helpful in doing so.

I also don’t see any indication in this post that they are talking about Revit.

Yes, OP could break down the issue some more for us, but I do believe they are referring to the Core Runtime and they had downloaded and unzipped it.
image

It also seems like @titomoura attempted to launch the package manager window and it crashed when loading. @titomoura when unzipping the core runtime, did you “unblock” all the DLLs and unzip with 7Zip?

1 Like

Check icon in the top left corner of the screenshot. :wink:

Ah. True. But the base point remains that reiterating this nonsense.

does not contribute much.

Because even if the user built Dynamo from source. Which is very doable. Then that is “installing it”.

Hi, thank you for replying I didn’t do it.

It would probably help to get more information on your environment. Can you go to help> about dynamo and screenshot that for us?

1 Like

I did it in a dumb way, I unzip that and then try to run the install.exe and it didn’t work, and then I tried to run the others files.exe. So when I opened one of them the dynamo main poped up and so I had an idiot idea of replace all the Dynamo 2 folder by the new one, after that this message keep happening, once I try to download new packages… I know I fucked it up.

Ah I see what may have happened. So yeah, to piggyback on @JacobSmall’s original comments.

There really isn’t an easy way to “upgrade” dynamo for Revit 2020+. There are workarounds, but they are difficult, unsupported and unstable for daily use.

1 Like

Spent some time thinking about how to resolve this, and I think the way out will vary depending on if you’re using 2020 or another version.

For anything but 2020 the fix I would try is an uninstall of D4R and complete delete of the folders which were previously overwritten (they may not get cleaned by the uninstall), and any hanging entries in the registry. Then install Dynamo 2.0.3 to get stood back up.

For 2020 I think an uninstall of Revit 2020 will wipe the folders for you, but you may need to check the registry still. Then do a full Revit 2020 install, including the updates as applicable to your organization and teams (ideally everyone is on 2020.2.1).

Thank you. I will try this weekend, if it works I let people know here.

1 Like

I get it sorted. I uninstalled and then deleted the dynamo’s folder and then I followed the steps of method 6 in this link http://www.uninstallhelps.com/how-to-uninstall-dynamo.html

1 Like