Print PDF naming issues

Hi Forum,

I’ve been wrestling with the print PDF node for a few days now and using the topics on here got it to work.
The only downside (besides the merging) is that it just ignores my directory input and file name and creates a default one.

I’ve been trying different list setups and lacings (there are a few setups that work with the Genius Loci node) to see whether that was the issue but none of the setups that do print have the right file name…

Here i get the current directory and change folders (because I dont want the pdf’s in the same directory as the rvt file

I compile the file name from several strings
PDF namme and directory set right
The file directory and file name are set right in the watch nodes

bluebeam save
But when the pdf printer pops up, it shows the wrong directory and the wrong file name…

I’ve tried a different pdf printer, but I had the same problem…

Does anyone know where I’m going wrong?

Print Sheets as pdf (help-version).dyn (92.0 KB)

Hi @Timdarkloto,

The issue is probably with the setup of your virtual PDF printer and not in the Dynamo graph.
Which PDF printer do you use ?


I am using Bluebeam or PDF24, both give the same export name

In most pdf printers there is a setting that specifies whether the printer should ask you to specify a name manually (Bluebeam has that, not sure about PDF24). If this is turned on it overrides the naming specified from within.

1 Like

I think as Alban its a setup issue…try to check this setup here for pdf24 but it should be similar with other printers as well…

PS…if you use bluebeam, then make sure you had admin rights to change these settings…


I’ve used the same settings as yours but still get the same issues.
Also set the settings in bluebeam to not ask, but still get a default name. Now it just throws it in my documents…

1 Like

Hi @Timdarkloto …I had tested your graph it works…looks like your dont have exactly the same count of printsettings as view try list.cycle…here i had clean your graph a bit for testing …give it a try…I had tested on PDF24…

Print Sheets as pdf (help-version).dyn (46.1 KB)

1 Like

Sorry for the late reaction, I don’t have access to revit/dynamo at home.

I match the papersize to the printsettings, which make sure that I get as many print settings as the amount of sheets.

I also tried your script but I still get the automated name

Hi @Timdarkloto …im normally dont use pdf24 but after i had take a look at it, it seems like the printer only support one fixed path i guess…what you could do here is move the file after print.and delete the temp folder after…think actuelly prosheet from diroots as use pdf24 …handle it this way as well…

Hi there.

I use PDF24 for all the printing within the company. Set the printer as on @sovitek 's snip and try feeding Genius Loci print pdf node with list structure as below.

Remember to add a string before your desired file name, so the FilePaths input gets a real file path, e.g. C:\1234.pdf.

Unfortunately still no success…

I’ve set the pdf settings to the snippet that @sovitek posted

And I’ve reduced my script to the absolute minimum to see whether this will work.

But alas, i still get this:
revit output

Edit: heres the file if anyone wants to check it, it’s as basic as I could get it and it only uses GeniusLoci. Print pdf basic.dyn (30.0 KB)
I’m running Dynamo 2.3, I don’t know if that has any consequences?

Sorry, I meant something different. It doesn’t need to be of filePath type, it’s a regular string. See below. Set the path to ‘C:’ and work with the filenames like with typical strings.

No need to convert it further.

Does this work for you? Because I can’t get it to work :frowning:

Yes, it does work for me.

Try adding ‘Desktop’ to the Strings to erase in filenames list in PDF24. If that does not work it might be some permission issues with accessing LAN drives by the printer. Maybe set up a different folder that’s on your local machine and give it another try.

Well whenever I use Bluebeam pdfs always end up in “Documents”, using it with Dynamo or with Naviate doesn’t matter.
So check for that.
Also check if the printing setting is compatible with the printer.

1 Like

I’ve set it to a desktop folder, and even my documents nothing works :confused:

@viktor_kuzev I ran a script that creates the printsettings for the printer, also the files themselves are correct, it’s only the name and location thats wrong…

I tried the ‘Print PDF in Document (multiple formats)’ node from GeniusLoci and I’m 50% of the way there; now the name is correct! However the path is still wrong… So somewhere the printers (tried both bluebeam and PDF24) do register the file name but discard the directory path.

Hi @Timdarkloto …it looks like the pdf24 printer only support one fixed path, thats why i move the files and delete the tempfolder after…

Hi @viktor_kuzev …its possible with Bluebeam to write to custom folder, you will need admin rights to change these setting…I cant test it as i dont have bluebeam in the moment,

Yes, in the Bluebeam admin there are three options - source folder, last saved and custom, as specified here: Changing the default folder options
I have tried them all and none of them seems to acknowledge the filepath specified from within a script (same with the Naviate Publisher that we use for printing)

1 Like

It’s such a shame but I have a feeling this is the only way…

Can’t wait until we upgrade to 2022 so that I can just export from Revit.

@viktor_kuzev Just read the help page from bluebeam, the source folder only works when creating pdf’s in Stapler, the PDF printer defaults to ‘my documents’ when source folder is selected

1 Like