Renaming PDF Files?

Hi Everyone -

I’m somewhat new to dynamo - been toying with it off and on for the past few months as I have time between tasks here. But something Konrad posted ( really grabbed my attention as something that would help out my workflow immensely if I could only figure out how to make it function.

I followed the post, I can make the script print my view set from Revit and it’ll name the files they’re Revit default naming, but I’m struggling on where the rename files node gets plugged in, so it’ll rename those files that were printed. I’m still fairly new to all this so I’m probably missing something incredibly obvious, all report out in dynamo indicate “success” … but the rename isn’t actually renaming right now.

I’m posting the image of my dynamo workspace - and a link below just in case that doesn’t function. Any help would be immensely appreciated.








More recent workspace



its the Identifiers input into Rename Node. Please read my post again, and pay special attention to what I was saying an identifier is. Tip: It’s not a Sheet Element.

Thanks!! - can’t believe I missed that the first time. Got it all up and running now


Hi Chris

Any chance you could post an image of your working code as I just can’t get it to rename the files after printing them?


Follow the link to archi-lab post that the original OP posted on top of this page. Please pay attention to details. All images and information required to make this work are posted on my blog as well as source code.

Hi Konrad I’ve got it working of a fashion but I seem to have to run it twice - once to print the pdf’s, then again to rename them. As it stands I may as well just print from the standard print dialogue and the run the rename bit on it’s own afterwards.




First of all thanks for the great work Konrad

I seem to have a similar issue to Andy Webb, having to run it twice to change names. I have to say I use PDFCreator and not Adobe PDF printer

Could you please explain if this how it suppose to work, or we’ve gone wrong somewhere. Chris could you please share your final working screen shot

Thank you all in advance


I have a question this was working great but i have begine to have an issue with my rename starts to distroy my pdfs im not sure why but it just begain.

anyone seen this before?

Dywayne, I’m having a similar problem. Did you ever find a solution?

Hi Dywyane, I am now getting this too. It has happened after updating Dynamo to and the Archi-lab package to 2016.2.10.

The problem seems to be with the “rename files” node. If you double click on the node it will open it in a new tab. Copy the python script node from here and paste it into your script and re-wire to this instead of the “rename files” node. This seems to get it working again, although it ignores the RunIt flag and runs whether true or false!





I’m having a similar problem as Dywayne with the above dynamo graph. (I ran the graph and it renamed everything in the directory with a single number or letter and no pdf file extension)

I tried Andy’s solution as described above but that didn’t work (nothing got renamed).

I running the latest stable build; Dynamo 0.9.1 and the latest package 2016.2.10 (on windows 7 professional with Revit 2015 R2.

Any ideas much appreciated.

hi! thanks ANDY WEBB!

It´s true, if you replace the “rename files” node for " pyton script" the dynamo run correctly.

Dario/Andy, would you be able to post some screenshots explaining the workaround? I have tried what was described, however I’m still getting the same error and single letter renaming. RVT 2016 - Windows Server 2012 R2

Hi, same results here. @David Fraser, try double clicking the “Rename Files” node body and enter in “custom node editor mode” (read: yellow canvas). Once inside the node, again double click the Python Script Node. Copy the script to clipboard and then go to your main workspace, put a Python Script Node on the canvas and paste the script inside.

Contrary to others, I need the “true” input to proceed renaming files.




Miguel Salvador

Hi there,

How you get the node to work?

I have been trying with the node, copying the python script… but I did have any luck at all.

Thank you very much.