Place space Tag

Hello Dynamo community,

has someone an idea, why i can´t place an space tag?

Thank you for your help.

Could you post again with the results window showing please?

one two

Hello Sean,

maybe it´s a problem with the german version of Revit i use, i´ve tried it in the english version.
But something wired happend. The node works, but it places the annotations far far far far away, an it still have the binding to the space. However that may work :smile: -)

What version of Revit are you in? The error appears to be saying that that the Method is wrong and according to the API reference the method changed in 2018.1.

What package version is the Create Annotation Tag node from?

Revit 2019.2
Dynamo core 2.02.6826
Dynamo Revit 2.02.6833
archilab v.

Try upgrading your archilab to the latest version and see if that helps.

Hi Christoph,

The Tag creation changed in the Revit API.
You can use Create Independant Tag in Genius Loci package instead.
This is an update of the Create annotation Tag node.
Thanks to Konrad Sobon for making the original one.

1 Like

@Konrad_K_Sobon, is this method changed in your current package?

Everything works just fine, when I change Revit to english and change the project units to decimal feet.

So I converted millimeters to feet.

And I changed the pyhton script of the node to the german catagory name.

Sorry for picking up an old topic, but i have kind of a similar problem.
When I’m about to create the annotation tag i get a typeerror: “expected View, got str”.

Dose anyone have an idea what the problem can be?

Connect the All Elements of Category to the Bool Filter node, not the Get Parameter node like you have now. Currently your passing it the parameter value, not the actual element.