Nodes Disappear

I worked up a script to assign the associated level parameter values to a custom project parameter (scheduled level) for all pipe elements (pipe/pipe fittings/pipe accessories) so that i can properly schedule them on a per floor basis. i had the script working as i thought it should and saved and closed out but when i open it back up there are nodes missing from my script, in particular the two nodes that select the required elements of each category. I’ve replaced them twice now and they just keep disappearing. has anyone else encountered this issue and know how to troubleshoot? I’m running Revit 2019 with Dynamo version 2.0.4.

Make sure that your Revit is fully up to date as well (2019.2.2) and check for dependency issues with other add-ins (the ! symbol at the top of Dynamo).

Revit is fully up to date to the 2019.2.2 version and i don’t think i see any dependency issues. when i click on that ! symbol the two lines are grayed out.

Before Closing Script

After Reopening Script Again

Can you upload your script so we can inspect it. Looks like either the nodes aren’t getting serialised/deserialised or when workspace is loading, some nodes aren’t getting drawn.

Also, what happens when you do a SaveAs of the workspace when it is complete? Does the saved as graph have the same problem? Also, have you tested on another PC? If so, does the problem persist?

Out of curiosity, do you have any view extensions installed in dynamo, I’ve seen this happen when an error has occurred while dynamo is drawing the workspace causing some nodes to not draw.

sure, see attached below. I’m still very new to Dynamo so i feel like it could be something simple i’m missing but i think i have everything right as far as the script goes because it generally does what i need it to (still needs some tweaks but it does function). i tried the save as to my desktop just to make sure it wasn’t also a network issue but that still does the same thing. I haven’t tried this on any other PC’s, i’m really the only one in my office that uses this at the moment. as far as view extensions i don’t believe i do, everything i have is ootb for the most part, except for the archi-lab package but i just downloaded that a little while ago, after this issue started.

Applying Level To Pipe Items For Scheduling.dyn (40.3 KB)

The nodes are there, so it’s likely associated with your installation or unique setup.

  1. Restart your cpu
  2. Launch a new revit session and start a new model
  3. Launch Dynamo for Revit, and open the graph. Then collect the most recent Revit journal from C:\Users\*USERNAME*\AppData\Local\Autodesk\Revit\Autodesk Revit 2019\Journals (just the journal.****.txt file) and the most recent Dynamo log from C:\Users\*USERNAME*\AppData\Roaming\Dynamo\Dynamo Revit\2.0\Logs (just the dynamoLog_XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX.txt).

Post those two files here and hopefully we’ll see what the issue is.

when this happens it’s almost always (always in my experience) an addin.

1 Like

See attached journal/log files you requested.

journal.0120.txt (202.3 KB)

dynamoLog_66ecdb5f-3ac5-4104-b4a7-114d91176cfe.txt (4.2 KB)

@Michael_Kirschner2 no indication of a conflicting add-in or any of the common issues here… any other ideas?

In the past we had a user who faced similar issue.
He installed Dynamo through Self Service Portal by ManageEngine Desktop Central.
For us the solution was to uninstall and the ask IT to install it using their admin privilege.

I think a good debugging step is to try dynamosandbox.exe to see if it works or reproduces the same bug.

1 Like

i’ll try the sandbox route and see how that goes. thanks for your help with this guys i appreciate it.

this is what i get when i open in dynamo sandbox

well, thats expected because those nodes are revit nodes.
But I see that the string node that was disappearing before, is now loaded fine…
So either something in the Dynamo version fixed it, or it’s some conflict in Revit.
Can you try the same version of Dynamo sandbox as you are using in Revit?

Michael - these are the two version i have installed, but i’m not sure which sandbox version equates to the dynamo version i’m using in Revit. Both are the latest available as far as i am aware. if there is a different one on this list i should install please let me know which.

ahh, I forgot distribution method changed around 2.1 - you can try install 2.3 sandbox to see how it handles opening the file.

I don’t think you are doing anything wrong user wise, can you try uninstalling all addins from Revit, and also all packages from Dynamo to test?

Can you take a look in ProgramFiles for DynamoCore/2/DynamoSandbox.exe? That might be version 2.0.4.

It is actually 2.0.4, you are correct, my mistake. i opened the script again in that version and it looks the same as the screenshot i posted above from the first time i opened it in sandbox.

so given that the same version of dynamo opens the script fine (the unresolved revit nodes are expected since those only get loaded in revit) - it semi-confirms my belief that the issue is some Revit addin conflict.

It would not be obvious from a log - the issue is about assembly resolve handlers being handled in arbitrary order by addins in the same process. Not much to be done besides find the addin and ask the authors to only handle their own resolve events and to not throw exceptions inside these handlers.

alright so to troubleshoot this, rather than completely wiping all my add ins out, i’m guessing i should remove one at a time and then test to see if the script works again? i have quite a few Autodesk add ins, so i’m thinking those should be okay? I also know of a few 3rd party ones i have so i’ll probably start there and see if any of those are the cause.