No preview visible in Dynamo


#1

I’m trying to learn Dynamo (just started tutorials yesterday.) I can’t get the background preview to work, or get the Watch 3D to work, or see anything happening in the Revit workspace. What am I doing wrong?Capture


3D Preview and 3D Watch not working
How to create lines using Excel data as coordinates
#2

2015-05-22_09h20_30


#3

I’ve had that turned on the whole time. I’ve tried zooming in & out, & panning around in case the geometry’s somewhere off screen. Nothing’s visible anywhere.


#4

Weird, a little more info? Revit version, Dynamo version OS version?


#5

Revit Arch 2015, Release 3 Build 20140606_1530 (x64)

Dynamo 0.8.1.1182

I’ve been following the second tutorial video, Anatomy of a Definition, and duplicating it exactly, but when I plug in my Watch 3D node, it stays blank. Not even the background grid shows up. Ditto for the View/Background Preview/Show.

I’m running all this on a virtual network. Can’t give you the specs for that because my IT guy just left for the holiday weekend, the slacker. We’ve been running Revit arch 2015 on this network for quite some time and have no known bugs that would impact Dynamo. I installed Dynamo yesterday and didn’t get any errors or weirdness during the install or when I open & run it. Any ideas?


#6

Heard of people having issues with virtual machines and I’m not too sure. Someone else may have to weigh in on this one.


#7

Very strange? Perhaps the Watch window is zoomed in to close / panned to the side. I’ve had this happen to me (though on the background view), but same applied to the Watch3D node:

Right-click on the node (not on its display but on its title or in between the > input and > output blocks). Then you should get an option to “Zoom to Fit”. At least that works for me in Dynamo 0.8.0 in Revit 2015 (Building Ultimate) in a VM running through VMWare Player installed in Kubuntu with Win7-64-Pro installed in the VM.


#8

Zoom to Fit doesn’t have any effect. I’ll have to try installing on my desktop and see if I have better performance with that than on my virtual.

We’re using VMWare + Windows 7 64 too. I’ll have to work with IT this week and see if we can identify the problem.


#9

Hi James, could you try with a daily build after 2015- 05 -21? I had the same problem with visibility and geometry when working in mm.


#10

I’ve solved it. The build I was using (Dynamo 0.8.1.1182) was unstable. I unistalled and reinstalled ver 0.8.0.950 and the preview and watch 3d work properly now. I might try Dimitar’s suggestion and use a more recent build so I can keep up with changes to the app, but at least for now I’ve got a version I can learn with.


#11

I would like to add it may also have something to do with a Virtual Machine (as John suggests). I have the exact same condition in my VM.

Version 0.8.1.1942


#12

We have the same issue of the geometry not showing up on our Server 2012 machines. We have the 0.7.5 version installed side by side the 0.8.1 version.

Dynamo version: 0.8.1.1823

Revit version: 20140303_0715 (x64) update Release 7


#13

I’m having the same issue with geometry preview not showing in version 0.8.1 when working through a remote sessions or a virtual machines. I started this thread earlier. It’s also been reported through Github here. Hopeful a fix is on the way.


#14

Came here to ask the same thing.

I just installed Revit 2016 & SP1 on my home machine. Then Installed Dynamo 0.8.2

The machine is a bit old (2010), but runs Revit 2016 fine.

I see nothing when I activate the 3D Preview mode, whether by clicking on the icon (lower right corner) or View…

The palette goes gray, so I can see its doing something, I just can’t see any graphics.


#15

Dynamo 0.8.1+ does not show 3D geometry in virtualized environments or on remote desktop. This is due to the lack of support for a software fallback. When running in those environments you are often seeing a software-rendered version of the background and NOT hardware accelerated 3D.

We are working on a solution for an upcoming release. The work around currently is to use Dynamo on Revit in a local evironment


#16

Any update on this issue? I am having the same problem with 0.8.2 running within Parallels on Mac running Windows 10. No geometry preview. One workaround I found is to disable DirectX all together in Parallels:

Shutdown the Virtual Machine

Go to Settings of the Virtual Machine in Parallels

Click on the Hardware tab

Click Video

Set 3D acceleration to Disabled

Restart the Virtual Machine.


#17

A little blue birdie told me that this might be fixed soon:

 


#18

I get a similar issue, but I do not run on a VM or Remote. I run everything locally. The Revit preview works fine, but not the Background Preview.

Any suggestions?

 

I am running Revit 2016 service pack 2 + dynamo 0.9


#19

Hi Jean, if you are running on a machine with integrated and discrete graphics, like many machines made these days you can try going into the settings for your graphics card and setting High Performance mode for Dynamo in the ProgramFiles/Dynamo .9 / DynamoSandbox.

It may also be an issue with a specific graphics card, what type do you have? Are the drivers fully updated? Version of Windows?

 


#20

My Graphic card is a NVIDIA Quadro K2000M running on Window 7 on a powerful HP laptop (24GB of memory, SSD drives).

The NVIVIA control panel does not have a"High Performance" setting, instead it has a set of specific settings: Anti-Aliasing, Buffer-Flipping, etc. Any suggestion on which one I should adjust.

I tried changing a few settings with no effect.

Regards