Missing 3D preview


I just started Learning about Dynamo and can’t figure out, why I don’t see the 3D grid preview in the window. everything is just white… - see attachment.
I have tried to disable 3D hardware acceleratiuon in revit and is wondering wheter I need an update for Dynamo. or is something else not set up correctly?
Also, do I need to update Dynamo seperately, when Dynamo is a part of my Revit License?

My build number for Revit is displayed under here:

This is likely a graphics card issue, which I think others resolved by disabling the intel graphics card.

As @jacob.small said, this is a graphic card issue, which can be solved by disabling the intel graphics card and also updating your Dynamo to the the newest version. If it is already updated, then you may want to uninstall dynamo and reinstall it.

Look at this here…

Hi again
A little background info that I left out in the first post:

  • Windows 10
  • Revit 2018 - Subscription With Dynamo included
  • Dynamo 1.3 - Integrated With Revit
  • Nvidia Graphics card

There has been a lot to do, so haven’t had the time to look at this before now.
But I have disabled the Intel Graphics card and updated the Nvidia Graphics card, but the 3D grid and axis is still not showing.

Wondering if i should reinstall Dynamo but is there a risk to “damage” the Revit application if I uninstall Dynamo, when it is integrated With Revit?

I have looked in the “Applist” and see 3 apps:

  • Dynamo Core 1.2.2
  • Dynamo Core 1.3.1
  • Dynamo Revit 1.3.1
    Should i uninstall all or just one?

And how do one reinstall Dynamo. Our office have a Subscription for Autodesk software and support to install/update everything, so I don’t have a link to Autodesk to use for this.


Okay. It seems that you had two graphic cards installed on your PC. I read somewhere that having two graphics card might not let you see the geometric preview in Dynamo.
Since, you have disabled one of your graphic card, and it still doesn’t seem to solve your problem, I would suggest you to update Revit and Dynamo from the Autodesk Desktop App. It is seen that it generally solves the problem you are having. Likes are always appreciated.


1 Like

Ok, to sum up

Basic info for current installation:
• Windows 10 Pro - 64 bit
• Revit 2018 - Subscription With Dynamo included
• Dynamo 1.3.2 - Integrated With Revit
• Nvidia Graphics card: GeForce GTX 1050 Ti

So far i have:

  • Disabled the Intel Graphics card and made NVIDIA the assigned Graphics card for Revit and Dynamo - and in general.
  • Updated Revit to build number 2018.2.0.51
  • Uninstalled and reinstalled Dynamo - newest version: 1.3.2 from the Dynamo website
  • Updated drivers for NVIDIA Graphics card.
  • Restarted Windows several times.

Still, I don’t see any 3D grid or axis in Dynamo.
I am running out of ideas, and thinking I might just wait for Revit 2019 and hope it works then…

b.t.w , nainoor I am giving you a like for the support. Tanks!

This may sound crazy but… try turning off hardware acceleration. If that doesn’t work (the crazy part is now) try disabling the nvidea card and using just the intel one.

1 Like

Hi Jacob

Hardware Acceleration is turned off and I have tried to use settings with both Intel and NVIDIA as the main graphic card.
I think it is time to cut my losses with this one and hope for a future version where I don’t have to be a computer wizard just to start it up…


is this solved ? if yes, how? I am using Revit 2021